Page 1 of 1

Fixing my AQ M4... no power

PostPosted: Mon Feb 29, 2016 6:12 am
by Mullet
So I did a no no and applied reverse polarity, not once but twice to my M4. The first time I lost the ability to use the ON/OFF switch. This was from plugging in a battery that was set up to have opposite polarity and I didn't realize it. Later on a few months later, I was switching the Losi plug and you guessed it... it was wired backwards. Not paying attention to this fact, I ended up toasting my M4 further.

Moving forward... I found this website -

I bought a new On Off IC - Max16054 and the battery charge circuit - BQ24075-Q1. First I replaced the On Off circuit and then I tested it. I was able to get power immediately when plugging in a battery. The On / Off switch didn't work. So I figured I'd move on to the battery charge circuit. I used the hot air station and solder paste method with what I thought was success. No I get no power at all.

What should I look at next? the DMN2004DWK dual channel mosfet or the the 3v3 buck boost or both? Could I have fried the fet and that's why it's not working?

Re: Fixing my AQ M4... no power

PostPosted: Mon Feb 29, 2016 9:33 am
by JussiH
Most likely you have fried the dual mosfet and possibly also the battery circuit. Usually the Buck converter survives, but damage cannot be ruled out....

But even if you replace those, it might still not work. You are likely to have burned out an internal trace.

Frying the FETĀ“s should not make problems for starting up the board.

Reverse polarity is a big No-No.... :(

Re: Fixing my AQ M4... no power

PostPosted: Tue Mar 01, 2016 7:45 pm
by Mullet
Thanks for the answer. From what you're saying, I'm thinking that I inadvertently killed the dual channel mosfet with too much heat. Like you said, I most likely didn't fry the buck boost. Then again who knows. I'll try it and let everyone know if this works or not.

A quick note: I never thought I fried the motor FETs, just the dual channel mosfet.

Re: Fixing my AQ M4... no power

PostPosted: Tue Mar 01, 2016 9:35 pm
by JussiH

LMK how this pans out... :)

Re: Fixing my AQ M4... no power

PostPosted: Fri Apr 22, 2016 1:21 pm
by Mullet
So I'm still going at it with this board. I had replaced a bunch of things: On / Off switch, battery charger management, dual FET. The only thing I haven't replaced is the buck boost. Before replacing the battery management IC and right after replacing the On / Off switch I did have power again, but the battery charging wasn't working. So then I moved on to replacing the battery management IC. Then I lost complete power again. So maybe applying a lot of heat damaged something pretty badly. I could have killed the battery management IC when trying to replace it.

I do have another M4 that I am trying to use as a donor for some of these parts. I noticed that when removing the buck boost and dual FET I still get power indicator via USB connection. So maybe I fried something more on the original M4 -- maybe the USB termination chip? Or perhaps I burnt out a trace somewhere. At this point this is more of a science project to see if I can bring back an M4 from the dead.

Fixing my AQ M4 no power

PostPosted: Wed Feb 07, 2018 10:16 pm
by Bookernub

I have some strobes that require a 5v power source and I was thinking of using the MR16 to control them. Can the MR16 operate OK with a 5V power supply?

Thanks, Scott