Tuning soft frame

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

Re: Tuning soft frame

Postby Max » Thu Feb 25, 2016 11:32 pm

Patnet wrote:Which one is Motor 6 in the geometry? That's the red one in the graph.

They're listed by port # except -1, so in your case motor A is MOT_MOTOR5, B is MOTOR6, and so on around the circle clockwise.

Patnet wrote:It looks to me like only one motor is clipping (Motor 6).

It's hard to tell what the other 2 are doing since the red/green mostly obscure the others. And seems like C (green) is perhaps compensating for whatever B (red) is doing. Or maybe the other way around.

A good way to find an imbalance in the physical system is to look at MOT_PITCH, MOT_ROLL, and MOT_YAW outputs. They should all average around zero when in a manual mode hover w/out any pitch/roll/yaw control input. If not, that would be a good thing to fix first before a lot of time spent tuning PIDs. They don't have to be perfect, but if not then you will always have some motors working harder than others, and they will need extra overhead available to perform w/out clipping. Once you get into larger PITCH and ROLL imbalances, that gets harder to tune since the PID settings for those two axes are shared.

Patnet wrote:Could that be a bad ESC or motor?

Possibly. Or an ESC out of calibration (or different from the others). Or it could just be the physical CoG of the whole frame being off, or motor(s) not perfectly vertical, or props not actually being evenly matched (quite common for CW/CCW "pairs").

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Tuning soft frame

Postby Patnet » Thu Feb 25, 2016 11:40 pm

Thanks. MOT_YAW averages about -300; MOT_ROLL averages about -150 and MOT_PITCH about -250.
Patnet
 
Posts: 138
Joined: Thu Jan 29, 2015 10:24 pm

Re: Tuning soft frame

Postby Max » Thu Feb 25, 2016 11:41 pm

Patnet wrote:I'm just using a 6 channel transmitter

With new firmware you can turn off the mode and home switches and just fly manual mode with 4 channels. But if the Tx doesn't have knobs/sliders for the 2 extra channels, that won't really help. :(

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Tuning soft frame

Postby Max » Thu Feb 25, 2016 11:43 pm

Patnet wrote:Thanks. MOT_YAW averages about -300; MOT_ROLL averages about -150 and MOT_PITCH about -250.

Yea those are quite off. I would get those much closer to zero before going further. I typically consider +/-50 as "significant deviation."

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Tuning soft frame

Postby Patnet » Fri Feb 26, 2016 12:02 am

Max wrote:
Patnet wrote:Thanks. MOT_YAW averages about -300; MOT_ROLL averages about -150 and MOT_PITCH about -250.

Yea those are quite off. I would get those much closer to zero before going further. I typically consider +/-50 as "significant deviation."

-Max


What do you think can be the causes? In general?
Patnet
 
Posts: 138
Joined: Thu Jan 29, 2015 10:24 pm

Re: Tuning soft frame

Postby Max » Fri Feb 26, 2016 2:48 am

Patnet wrote:What do you think can be the causes? In general?

Pretty much what we've already covered... though that's probably not an exclusive list.

Max wrote:
Patnet wrote:Could that be a bad ESC or motor?


Possibly. Or an ESC out of calibration (or different from the others). Or it could just be the physical CoG of the whole frame being off, or motor(s) not perfectly vertical, or props not actually being evenly matched (quite common for CW/CCW "pairs").


-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Tuning soft frame

Postby Patnet » Fri Feb 26, 2016 4:24 am

Thanks, understood.
Patnet
 
Posts: 138
Joined: Thu Jan 29, 2015 10:24 pm

Previous

Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 0 guests

cron