Motor / Propeller Problem

The last Bastion to fine tune your FC matching your airframe & setup

Motor / Propeller Problem

Postby Luxar » Wed Dec 02, 2015 5:39 pm

Hey !
Using someone the MN3508-20 Motors with 15x5.5 CF props ? I'll need some help/PID's Tuning templates...
After i change the Motor/Props the copter are very nervous. I'll tune various PID's, but nothing helping....
Am balancing the props And so on....
Can someone help ?
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Re: Motor / Propeller Problem

Postby LPR » Wed Dec 02, 2015 9:01 pm

As usual to get help you have to first give much more information. We need a good photo, a parameter file, the type of ESC and it's setting.

The more you give the more you get.

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: Motor / Propeller Problem

Postby afernan » Wed Dec 02, 2015 11:46 pm

Hi:

I think 15x5 props are too much for good effitiency performances of that motor. I´m using 12x4 and works great. I´ve tryed 13x4.5 and it´s not so good than 12x4. Have a look to this mount:
viewtopic.php?f=25&t=4631

Angel
afernan
 
Posts: 1214
Joined: Sat Jul 07, 2012 5:24 pm
Location: Madrid, Spain

Motor / Propeller Problem

Postby Luxar » Thu Dec 03, 2015 5:55 pm

Thanks for help :)
Am using the Motor / Prop combination with 3S 5000mah, esc32 v2, ready to Flight weight is 2280 gramms. The Motor have 580 KV
ImageImage
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Re: Motor / Propeller Problem

Postby LPR » Thu Dec 03, 2015 8:41 pm

Ralf

You have a nice build but it takes quite a bit to get a quad to fly well using PID FW. Your props are probably ok because you have motors with a lower KV than Angels quad and you're using a 3s lipo.

Now it all comes down to seeing how much vibration you're getting on the SD card logs. Changing the PIDs setting and or changing your frame if vibration can not be lowered enough are the next steps.

Search the forum for other similar builds to find PID settings.

I attached an parameter file from an old build of mine that uses old FW and Simonk ESCs but it flies well. I would think you would be able to fly ok with these settings.

Larry
Attachments
AQ 6 old crash quad PARAMS.txt
(14.75 KiB) Downloaded 142 times
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Motor / Propeller Problem

Postby Luxar » Fri Dec 04, 2015 4:43 am

Thanks for help/PID's example ! I'll Test it later, if am back from work :)
If the weather get better, or am in a sports gym, i will make a Short logfile and share it...
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Re: Motor / Propeller Problem

Postby Luxar » Fri Dec 04, 2015 5:33 pm

Your PID's works good, i make a short Indoor logfile (hover on the floor, not good because some turbulences )
https://www.dropbox.com/s/z7hy8xsxp2gpj ... L.LOG?dl=0
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Re: Motor / Propeller Problem

Postby LPR » Fri Dec 04, 2015 5:53 pm

Ralf

I'm surprised by how little vibrations you're getting.

Looks like you'll have a quad that should fly well.

Look carefully at the new PIDs settings I gave you and slowly change them to learn how to get the best performance out of your quad.

My quad is very different than yours so I'm sure you can do better with more PID tuning.

Larry
Attachments
Raft first flight.jpg
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Motor / Propeller Problem

Postby Luxar » Fri Dec 04, 2015 6:18 pm

Sounds great! I think, am on a good way with vibrations And so on :) !
Hope, that I can fly tomorrow in the sports gym, to tune something. Thanks for helping
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Re: Motor / Propeller Problem

Postby Luxar » Fri Dec 04, 2015 6:25 pm

Larry
Am using the esc32 v2....
Sometimes the motors wouldn't start direct, only on second try...my esc settings are on the pic in earlier posting...pls have a look on it
Greetings from Germany - Ralf
Luxar
 
Posts: 53
Joined: Mon Dec 30, 2013 12:20 pm

Next

Return to PID Tuning

Who is online

Users browsing this forum: No registered users and 1 guest

cron