[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - Introducing the AQ ESC32 Configuration Utility (ECU)

Introducing the AQ ESC32 Configuration Utility (ECU)

Info and Discussion about the ESC32 hardware and software

Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Max » Tue Aug 25, 2015 5:06 am

Attachments
ecu_config_675px.png
ecu_config_675px.png (143.93 KiB) Viewed 14515 times
ecu_calibration_CL_finished_675px.png
ecu_calibration_CL_finished_675px.png (199.32 KiB) Viewed 14515 times
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Astudillo » Sat Aug 29, 2015 11:10 am

Hi Max,

Looks like a really awesome tool! But im trying to run in on my mac, and i get a error that i'm missing a library.
Library not loaded: /Users/max/Qt/5.4/clang_64/lib/QtSvg.framework/Versions/5/QtSvg

Installed QT 5.4 but still got the same message, so i made a user folder named "max" in my user folder. And copied the QT folder in it, and it works now.

Cheers,

Ray
Astudillo
 
Posts: 139
Joined: Thu Apr 25, 2013 8:23 am
Location: Amsterdam, The Netherlands

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby kinderkram » Sat Aug 29, 2015 11:48 am

Looks like there´s a wrong path in the setup, locally set to Max`user folder.
Thx for posting the workaround.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Astudillo » Sun Aug 30, 2015 4:46 pm

Attachments
Schermafbeelding 2015-08-30 om 16.51.06.png
IMG_3154.JPG
Astudillo
 
Posts: 139
Joined: Thu Apr 25, 2013 8:23 am
Location: Amsterdam, The Netherlands

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby kinderkram » Sun Aug 30, 2015 9:58 pm

Your problems are partitially related to the MacOS version - but the thrust part sounds strange.
Did you try to start with lower values than 6000rpm? Just to see if it acts the same...

Do you have access to a Windoze PC to compare with the Win version?

One important thing is the quality of the USB cable - but I guess you fully trust Apple. ;)
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Astudillo » Sun Aug 30, 2015 11:06 pm

@kinderkram the usb cable is actually from my samsung tablet :P

Ill borrow a windows machine at work tomorrow and check it out. I have to say that i had some trouble with my Usb(3) ports on macbook with the M4. That if i reboot the M4 from the QGC the whole systems freezes. On my old mac that doesn't occur. So i could check that as well.

I did try different rpm's, it also happend at 300rpm 900rpm,3000rpm and 9300rpm. The v3 was non responsive at arming or disarming,but did still show a active telemetry. But i had to reboot the V3 and than it would spin up, but not at the displayed rpm(despite pushing the enter key). Sometimes i just had to go up or down 50rpm to get it at the right rpm, but sometimes it stalled and one time it didn't stop spinning. But nothing consistently.

I will try it on another machine, and see if i can replicate the problem. I also wil look for some other micro usb cables to be sure. 8-)

Cheers,

Ray
Astudillo
 
Posts: 139
Joined: Thu Apr 25, 2013 8:23 am
Location: Amsterdam, The Netherlands

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Max » Mon Aug 31, 2015 4:38 am

Hi Ray,

Thanks for the reports, and sorry about the troubles. Looks like a packaging mistake on that latest Mac version, and I'll definitely look into the crash you described with telemetry/logging, and the log file name issue. The Mac version got significantly less testing than Windows, unfortunately. I also noticed/fixed a minor bug with the Connect/Disconnect button labels.

I'm not sure about the issues with running the ESC... The "ESC unexpectedly entered disarmed state" (when it is actually still running) problem can be due to telemetry data getting mixed up (it would also display "funny" values in the list/graph). Though if you didn't have a problem with the calibration run, that would suggest a decent USB cable/etc. How many Hz is the telemetry rate set to, and does that make a difference for this issue?

Before trying to run at a fixed RPM, I assume you set the FF terms on the ESC after the initial calibration? You could also try running from the command line interface to see if it makes any difference.

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Astudillo » Mon Aug 31, 2015 9:07 am

Hi Max,

Thanks for your reply, yes i saved the FF terms to permanent memory and rebooted. I ran the telemetry at 10Hz, i could try different rates. And ill check the Terminal.

Thanks for the input!
Astudillo
 
Posts: 139
Joined: Thu Apr 25, 2013 8:23 am
Location: Amsterdam, The Netherlands

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby Max » Tue Sep 01, 2015 5:55 pm

Update 1.0.1 is now available for Mac OS X. Fixes packaging problem with the Qt libraries, Connect/Disconnect button label, and default telemetry file name. Remaining known issue: app crash if logging is stopped while telemetry is running (will fix on next update).

Installer updated. If you already installed ECU, you can update using the included AQ_ECU_Updater.app utility.

Thanks again to Ray for the reports!

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

Postby kinderkram » Tue Sep 01, 2015 6:40 pm

I´ve added a note to the docu regarding the app crash.
Remove after the fix.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am


Return to ESC32

Who is online

Users browsing this forum: No registered users and 1 guest

cron