[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - Incorrect voltage shown in QGC and Terlemetry

Incorrect voltage shown in QGC and Terlemetry

Radio, Telemetry, FTDI/USB, ESCs, Motors, etc.

Re: Incorrect voltage shown in QGC and Terlemetry

Postby vAkUuM » Wed May 20, 2015 5:55 am

Hello All,
Still the same problem: on connection to GCS it shown zero v. I try to flash by different firmware but same result. Any suggestion?
Thank you, Valentin.
vAkUuM
 
Posts: 21
Joined: Thu Apr 24, 2014 4:36 pm
Location: Riga, Latvia

Re: Incorrect voltage shown in QGC and Terlemetry

Postby aBUGSworstnightmare » Wed May 20, 2015 6:09 am

aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Incorrect voltage shown in QGC and Terlemetry

Postby vAkUuM » Wed May 20, 2015 8:12 am

Hi Joerg,
Thank you for quick answer. Yes, flashing was successful. I flashed it with 6.7 and with 7.1. All functions are working correctly. Only this problem with voltage. And off course I can not fly because motors are not working properly :(
I have not any ideas how to fix it for a long time.
Thank you, Valentin.
vAkUuM
 
Posts: 21
Joined: Thu Apr 24, 2014 4:36 pm
Location: Riga, Latvia

Re: Incorrect voltage shown in QGC and Terlemetry

Postby JussiH » Wed May 20, 2015 9:20 am

You need to connect the Vsens/GND between M4 and N4

Then select "external voltage sensor" in misc settings in QGC. Write to flash and restart.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Incorrect voltage shown in QGC and Terlemetry

Postby vAkUuM » Wed May 20, 2015 11:39 am

vAkUuM
 
Posts: 21
Joined: Thu Apr 24, 2014 4:36 pm
Location: Riga, Latvia

Re: Incorrect voltage shown in QGC and Terlemetry

Postby JussiH » Wed May 20, 2015 11:46 am

JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Incorrect voltage shown in QGC and Terlemetry

Postby vAkUuM » Wed May 20, 2015 11:53 am

Jussi, sorry.
But I have Autoquad 6. My mistake, did not write about it. Can I do something with this board?

Thank you,
Valentin.
vAkUuM
 
Posts: 21
Joined: Thu Apr 24, 2014 4:36 pm
Location: Riga, Latvia

Re: Incorrect voltage shown in QGC and Terlemetry

Postby JussiH » Wed May 20, 2015 2:08 pm

AQ6 board has internal voltage sensor, it should work if the internal sensor is chosen under misc settings in QGC.

If not, it points to a problem with the board, most likely a connection problem on the voltage divider (R3 and R4) or connection problem to the ADC pin on the STM32 that reads the output of the voltage divider (Pin18).
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Incorrect voltage shown in QGC and Terlemetry

Postby vAkUuM » Wed May 20, 2015 2:50 pm

Heh,
It's looks like I can not fix it by myself. :( Very strange - all time it was powered from BEC by 15 v. No any visual defects. It was from the beginning. No one fly was made.
vAkUuM
 
Posts: 21
Joined: Thu Apr 24, 2014 4:36 pm
Location: Riga, Latvia

Re: Incorrect voltage shown in QGC and Terlemetry

Postby JussiH » Wed May 20, 2015 4:52 pm

Where did you buy this board?
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

PreviousNext

Return to Connections

Who is online

Users browsing this forum: No registered users and 2 guests

cron