[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - Red LED on AQ with DIMU and new firmware

Red LED on AQ with DIMU and new firmware

Info & Discussions about good ole AQ6, taken to the next level.

Re: Red LED on AQ with DIMU and new firmware

Postby rput » Fri Apr 25, 2014 1:29 pm

rput
 
Posts: 83
Joined: Sun Feb 10, 2013 5:45 pm

Re: Red LED on AQ with DIMU and new firmware

Postby afernan » Fri Apr 25, 2014 2:32 pm

OK. You have a bigger problem first.

If you can´t connect to AQ you´d try to start again by installing a new fw. You must can doing that. If not possible, maybe the board is bad or your FDTI cable is wrong or broken.

The solution I´ve shown above about DIMU red light "bypass" the problem, but at the end you can instal the DIMU deffault params and fly (with a little more of effort, but it works)

Angel
afernan
 
Posts: 1214
Joined: Sat Jul 07, 2012 5:24 pm
Location: Madrid, Spain

Re: Red LED on AQ with DIMU and new firmware

Postby rput » Fri Apr 25, 2014 6:20 pm

Thanks. I can still revert to the old firmware and everything works fine. This rules out a cable issue. Also, when I put in a different DIMU board it works fine (still have to put in the SD card with params file, but no debug light issue).

If anyone knows of something else I can try to figure out where the problem is originating I would love to hear it.

Cheers,
Richard
rput
 
Posts: 83
Joined: Sun Feb 10, 2013 5:45 pm

Re: Red LED on AQ with DIMU and new firmware

Postby farooq_niaz » Sun Apr 27, 2014 9:21 am

With FWr381hw6.1 The AQ was stuck on red light. Then I put the parameter file given by jussi in the sd card and then tried. Now it is stuck with 2 red lights. Logging is being done but no information is written in the file. I can't connect AQ to QGC.
farooq_niaz
 
Posts: 47
Joined: Mon Dec 09, 2013 6:16 pm

Re: Red LED on AQ with DIMU and new firmware

Postby farooq_niaz » Sun Apr 27, 2014 6:24 pm

I think there is something wrong with these board some bad soldering or some other components issue.

Jussi please advice
farooq_niaz
 
Posts: 47
Joined: Mon Dec 09, 2013 6:16 pm

Re: Red LED on AQ with DIMU and new firmware

Postby JussiH » Sun Apr 27, 2014 8:13 pm

I have not seen this problem before. If you suspect HW failure, then I need you to send the board back here for examination.

But first, try and load a standard FW for AIMU and confirm you have connection then. The reload DIMU FW and try again.

All the ready made boards was thoroughly tested. As were the DIMUs....but of course they could have failed in transit.

The red Debug light usually when you perform the tare. Im not sure if it also begins flashing at battery stage 2, but I think it does...Bill?

I have not had a DIMU that did not initialize without the DIMU parameters. We probably need to publish FWs with default DIMU params...will ask the devos to look into it.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Red LED on AQ with DIMU and new firmware

Postby Max » Sun Apr 27, 2014 8:38 pm

The 2nd red LED stays on when there is a PARAMS.txt file on the SD card. I'd double-check the text file (actually plain text and such), to avoid the same problem Larry was having last night.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Red LED on AQ with DIMU and new firmware

Postby farooq_niaz » Mon Apr 28, 2014 7:56 pm

So here is the resolution(or atleast a step forward)

The problem is poor soldering on the lower side as shown below on IMU, Magneto and baro

IMG_3718[1].JPG



Adding a little bit of solder paste and Heat and got following results after cleaning
IMG_3719[1].JPG


So now I can move forward and AQ boots when PARAMS.txt file is placed in SD Card.

farooq_niaz
 
Posts: 47
Joined: Mon Dec 09, 2013 6:16 pm

Re: Red LED on AQ with DIMU and new firmware

Postby JussiH » Mon Apr 28, 2014 8:19 pm

If all leds are flashing, you are triggering a compass calibration... Verify that your TX channels are set correctly. If you pull both stick to lower left and all leds begin flashing, then your elevator channel is probably reversed.

Yeah, thats some crappy soldering for sure - dunno how that passed QC, but I will tell factory to pay more attention :oops: Thanks for cleaning it up yourself.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Red LED on AQ with DIMU and new firmware

Postby farooq_niaz » Tue Apr 29, 2014 5:45 pm

farooq_niaz
 
Posts: 47
Joined: Mon Dec 09, 2013 6:16 pm

PreviousNext

Return to AQ6 +DIMU +CAN

Who is online

Users browsing this forum: No registered users and 0 guests