Page 1 of 5

DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 4:49 pm
by Crizz
Hey guys,

tried maidenflight today, but my x8 only flipped back when take off. So i searched the whole afternoon for reason and figured a strange behaviour :

when motors are disarmed, i see changes of degree in orientation at QGC, directions are correct. But it seems that on pitch (nick) axis, the values are too low, even on 45° deg. the horizon only moves around 5mm from neutral.

whem motors armed and running, i get no changes on pitch (nick-axis) shown, and the motors are running without any changes, so there is no even no cycle regulation - seems like really no sensor data comes to the MCU.

Is it a known issue ? How to fix it ?

Have made screenshot of actual params, maybe i did something wrong ? or should i change firmware ?

I was really close to crazy, this bird drove me nuts lots of time meanwhile so any help is appreciated very much ! :)

Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 6:36 pm
by chschmid
Hi Crizz
Did you calibrate the Sensors (mag & Level)?


Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 7:02 pm
by Crizz
i did TARE the DIMU right after installation, set mag. declination etc.

Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 8:12 pm
by Max
99% of the time (roughly ;) ) what you're describing is caused by the motor mix not corresponding to the physical setup... one of the rotations is wrong, or a motor is in the wrong position, prop is backwards, etc. With coaxes especially it is very easy to get mixed up... ask me how I know! :roll: I've been SO sure that everything was right, just to discover (eventually) that sure enough, something was backwards or flipped or a port was assigned incorrectly, or whatever.

Might not be the problem here at all of course, but just sayin'... check it all again, then again, then walk away, come back and start over like you haven't checked it already a million times. :) Also your IMU_FLIP and/or ROT(ation) parameters (in QGC Misc. settings).


Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 9:01 pm
by Crizz
I know about the problem with ports / wiring, had been my first issue on this project and i checked (dont laugh at me) with 5x3" props i directly pressed on the motor axles to asure proper rotating direction of all motors. I switched all outputs to CAN and checked port assignment switching only 1 output back to pwm and checked that the correct motor is running.

I mounted the AQ6 upwards, DIMU on top of board, flight direction assigned between the front outriggers - so there shouldnt be any value to bet set as rotated / flipped DIMU.

And like i already said :

While copter is disarmed, i have all sensor activity in HUD - but when motors run, there is no reaction at the nick axis (pitch). When i am tilting the copter and switch motors off, the HUD jumpos to the correct angle. But it stays at its starting position when i move the copter with running motors. This seems very strange to me, esp. because only 1 axis is a victim of this.

I guess the only way to check if it is the DIMU itself is putting it of the board and do the calibso and gather dynamic calibration instead of DIMU use to see if its still the same.

Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 9:31 pm
by Crizz
Update :

just checked again : motor directions and connections are correct with the x8 Caoax preset. And : it doesn´t make any difference if only one motor is running and the rest is not active (CAN) - when motor is running, no sensor-data for pitch (nick) axis are in HUD .

May it possible that i have overlooked anything needed to be changed for useage of DIMU instead of AIMU ? Any setting to be stored in QGC or any jumper to be set to enable DIMU ? Any other setting that need to be changed to avoid adress collisions from sensor boards ?

I have no problem to re-solder the DIMU with Hotair, but i cant hardly believe that it should be under bad solderwork.

Re: DIMU fail or FW bug ?

PostPosted: Sun Apr 19, 2015 10:59 pm
by Max
Did you d-load/install DIMU firmware? Should have -dimu1.1- in the file name. Otherwise there shouldn't be anything special to set to use it.

Not sure what's up... you could try posting your AQ and ESC settings (you can save both to files in QGC), a short log of the event, and perhaps a pic of your setup.


Re: DIMU fail or FW bug ?

PostPosted: Mon Apr 20, 2015 1:11 am
by JussiH
I dont think there is a problem with the DIMU itself, so dont break out the hotair just yet.

Start by Following Max´s suggestion and check if you have a DIMU FW loaded.

Then post a short log that has shows the problem and the MSG file that goes along with it. Then we can see if the DIMU is initializing properly and if the log shows a problem with the estimation when motors are running.

Re: DIMU fail or FW bug ?

PostPosted: Mon Apr 20, 2015 8:54 am
by Crizz
I checked existing log files, and all are empty ( 0 byte). So cleared SD-card and startet AQ, made movement on each axis in disarmed-mode, waited 10 seconds, did the same with running motors, waited 10 seconds ( all in all it had taken around 50 - 60 seconds ) and echecked SD-card again : Logfile and Messagefile empty :shock:

Must i enable logging at the v7 firmware separately ? with the older versions (w/o DIMU) it automatically logged.
I´m a little confused now - am i just to stupid for it ?

Edit : is logging only eneabled with GPS-fix ? Have just seen that files have "no" timestamp (1999) because indoor i have no GPS-fix

Re: DIMU fail or FW bug ?

PostPosted: Mon Apr 20, 2015 12:01 pm
by aBUGSworstnightmare
Hey Crizz,
Didn't expect to gain Access to the forum in the land with the largest (Fire-)wall of all ....

Logging is enabled by default. Simply plug-in a class10 uSD and done.
Please let us no the exact firmware version, build-no (check QGC, it's displayed there)