Old pids with DIMU FW

Info & Discussions about good ole AQ6, taken to the next level.

Old pids with DIMU FW

Postby leopold1 » Wed Jul 23, 2014 9:17 pm

After my close encouter with an AQ ;) http://forum.autoquad.org/viewtopic.php?f=24&t=3540
I reinstalled everything again from scratch and used the DIMU FW r406 again. And also looking out that all parameters were correct ;)

Onboard cal and tare went fine and stored everything.

But with the default pids it was quite unflyable. Yaw was uncontrolable and there was a fast oscillation.
Then I switched al my rate an angle pids back to the old ones from the non DIMU official fw. And it flies allmost perfect.

Someone give me a clue why this is?
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium

Re: Old pids with DIMU FW

Postby SuperSharpShooter » Thu Jul 24, 2014 4:07 am

I've had to turn down the PIDs from defaults on all my DIMU copters to get them to fly smoothly. Not quite to the level of the old defaults, but around 30-40% generally.
-Glenn
SuperSharpShooter
 
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: Old pids with DIMU FW

Postby leopold1 » Sat Jul 26, 2014 9:22 pm

Glenn,

Which pids did you turn down 40%?

I reduced the new pid values for 60% for
Tilt rate P
Tilt angle P,I and D.
The rest I didn't touch. Its flyable but stil that odd twitch that I don't have on the version without DIMU.

Another question. I'm using Menno's r402 FW but I don't know if he uses default pids?
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium

Re: Old pids with DIMU FW

Postby Max » Sat Jul 26, 2014 10:19 pm

For comparison, you could try out the other firmware I posted here, starting with default Tilt PIDs.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Old pids with DIMU FW

Postby leopold1 » Sun Jul 27, 2014 10:32 am

Max,

I loaded your fw and apart of the MPU filtering the pids are all the same as Menno's r406.

At first glance the test flight was more stable with small fast oscillations that was reduced to a minimum by reducing tilt rate D to 12000.

When I read the postings from http://forum.autoquad.org/viewtopic.php?f=27&t=3269&start=40 I get exactly the same motor "zinging". And it gets worse when hovering low (due to downwash)
Also when flying tilt and pitch a little bit faster you can here them motors zinging.

Hope this helps in finding a solution.
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium

Re: Old pids with DIMU FW

Postby leopold1 » Sun Jul 27, 2014 10:45 pm

Just went back again to the 6.7 stable version from the download section and my quad flies great without DIMU.
I'm concluding that it has nothing to do with vibrations or setup.
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium

Re: Old pids with DIMU FW

Postby leopold1 » Thu Jul 31, 2014 1:08 pm

Any more suggestions concerning the strange behaviour.

I'm going abroad for a couple of months and I'm thinking of taking the quad with me.
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium

Re: Old pids with DIMU FW

Postby hogster » Fri Aug 01, 2014 8:07 am

leopold1 wrote:Just went back again to the 6.7 stable version from the download section and my quad flies great without DIMU.
I'm concluding that it has nothing to do with vibrations or setup.

Hi Leopold,

That is very interesting to hear, particularly that you were also experiencing the same 'zinging' problem as I'm having on my platform.

Can I just confirm that I don't need to remove the DIMU board if I want to go back to 6.7 and try using the AIMU?

My only fear is that I'm still experiencing quite bad shifts in my MAG values when hovering, and that with the AIMU this might have an affect on the stability of the platform ...?

Many thanks,

David :)
Attachments
2014-07-30_2019 MAG plots.png
MAG plots
hogster
 
Posts: 239
Joined: Tue Feb 11, 2014 8:59 am

Re: Old pids with DIMU FW

Postby leopold1 » Fri Aug 01, 2014 3:51 pm

When I switch back to the AIMU Fw I remove DIMU just in case ...
I would like to film the behaviour but I don't know if you will be able to hear the zing. Or maybe a log could shed some light??

One thing I don't have is a drift.

Nevertheless I hope it gets resolved because the only big advantage for me at the moment with the DIMU is the alt hold. It works very good!
leopold1
 
Posts: 311
Joined: Tue Jul 31, 2012 11:43 pm
Location: Belgium


Return to AQ6 +DIMU +CAN

Who is online

Users browsing this forum: No registered users and 3 guests