QGC shows incorrect heading after Onboard Magnetic Cal

Info & Discussions about good ole AQ6, taken to the next level.

Re: QGC shows incorrect heading after Onboard Magnetic Cal

Postby SuperSharpShooter » Tue Jun 17, 2014 1:40 am

I've just done a little more testing with a spare DIMU I have here. With this new DIMU, the board booted fine first time and I connected using QGC, but then when I powered it up again to do the calibration, it just sat there with the red power light on and wouldn't boot. I put the old DIMU on again, which let the board boot, changed the config version to 0 and sent the parameter and wrote ROM, and installed the spare DIMU again, which let the AQ board boot again.

I ran through the mag calibration with this DIMU, and redid the level then did the stick combination to write the EEPROM. The indicated heading looked to be more or less correct on the android app, so I gave it a 2 min test flight and observed that position hold was tracking correctly.

I powered this off and on again, and reconnected using the android app, but the heading would no longer display at all in the app, so I connected to QGC (after a fresh QGC start), and observed the heading wasn't updating there either. Ran the diagnostic telemetry, and most values were populated, but not updated, and a bunch of them (AQ roll, pitch yaw and all UKF) were displaying nan. I rebooted the board again, and it's back to not booting with the red power light on. I think this DIMU may be flakey.

So I put the original DIMU back on, set all the MAG and ACC offsets to 0 in QGC, sent and wrote ROM and rebooted the AQ. The heading was now displaying but was approx 50 deg off from what it should be. I reran the mag calibration and level calibration and wrote EEPROM, and gave it a quick flight, but the tracking in position hold was way off like it was initially, Commanding it forward would make it head about 40 degrees to the right of where it should. I rebooted again, and it seemed to be indiciating the heading closer to correct, and tracking in position hold now seems to work ok.

Edit: Just took it out for another flight, and the initial heading still isn't correct and it tracks off to the side in position hold, but then straightens up after a minute... so I'm back where I started really.
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: QGC shows incorrect heading after Onboard Magnetic Cal

Postby LordPikaChu » Tue Jun 17, 2014 8:17 am

I won't be of much help since I had severe MAG issues in my previous build myself, but just wanted to point out that I think that MAG is used exactly to determine heading in position hold mode. In the past, MAG was also used to determine the level of your copter, but I think that I have read somewhere that it's no longer the case, but I can't be sure until someone from development team chimes in and confirms this.
Posts: 93
Joined: Fri Aug 09, 2013 12:42 pm
Location: Poland, Lodz

Re: QGC shows incorrect heading after Onboard Magnetic Cal

Postby johandm_be » Tue Jun 17, 2014 9:47 am

Thanks for doing these tests and sharing the results Glenn.

My 2nd DIMU also does not work. I tried it on 2 AQ boards yesterday and both AQ's refused to boot when that DIMU is installed. This is a brand new DIMU, it was still in its sealed wrapping until now. I will be shipping it back for a replacement.

I am also curious to know whether the problem of faulty heading readings would be better with a different DIMU board.
I will pick up this test again when I receive the replacement part.

Posts: 40
Joined: Tue Mar 12, 2013 3:27 pm
Location: Belgium


Return to AQ6 +DIMU +CAN

Who is online

Users browsing this forum: No registered users and 1 guest