Unable to write parameters to ROM after DIMU upgrade

Info & Discussions about good ole AQ6, taken to the next level.

Re: Unable to write parameters to ROM after DIMU upgrade

Postby SuperSharpShooter » Wed Apr 02, 2014 8:29 am

Joerg, mine does the exact same thing with r368. I'm currently running r357 and it saves the params OK. Haven't flown it yet though.

QGC 1.3.0 on Windows 7 x64.
-Glenn
SuperSharpShooter
 
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Wed Apr 02, 2014 8:40 am

SuperSharpShooter wrote:Joerg, mine does the exact same thing with r368. I'm currently running r357 and it saves the params OK. Haven't flown it yet though.

QGC 1.3.0 on Windows 7 x64.


Confirmed! Just verified this on Win7 x64 running in a VMware virtual machine. Same problem here. Will 'downgrade' to another experimental version now.

Joerg
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Wed Apr 02, 2014 9:18 am

Conducted further testing.
Flashed to aqv7.0.r360.b1673-rev0-dimu1.1.hex

Radio type parameter can be changed.
I've now tried to execute the TARE function (http://autoquad.org/wiki/wiki/autoquad- ... s-upgrade/) --> nothing happens; HUD keeps spinning around!
r360.tiff
screenshot, running r360


Flashed to aqv7.0.r362.b1679-rev0-dimu1.1.hex
Radio type could be changed; TARE fails too!

Same for aqv7.0.r364.b1683-hwv6.0-dimu1.1.hex!

EDIT: loaded Jussi's IMU parameters (viewtopic.php?f=42&t=3039&start=20#p20004) to the r364 board. Power Cycling the Board --> HUD works normal, but TARE is not possible. The error message 'DIMU: cannot read EEPROM parameters!' remains.
P.S. can somebody verify my radio settings were correct!
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby SuperSharpShooter » Wed Apr 02, 2014 8:55 pm

I had to reverse my pitch channel before I could get TARE to work.
-Glenn
SuperSharpShooter
 
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby sandmen » Thu Apr 03, 2014 8:14 am

I can reproduce the failure.
I'm working on that topic.
sandmen
 
Posts: 997
Joined: Fri Jun 22, 2012 7:25 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Thu Apr 03, 2014 8:17 am

Hi,

just tested aqv7.0.r371.b1702-hwv6.0-dimu1.1.hex; same result here!
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby bn999 » Thu Apr 03, 2014 3:06 pm

This bug has been found and fixed in the repo trunk head.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby kinderkram » Thu Apr 03, 2014 3:31 pm

The nightly build for r372 should then be online tomorrow:
ftp://ftp.autoquad.org/3/334693_22529/a ... erimental/
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby Max » Thu Apr 03, 2014 4:03 pm

I just forced a build and new versions are up on FTP.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Unable to write parameters to ROM after DIMU upgrade

Postby Astudillo » Thu Apr 03, 2014 5:17 pm

Hey guys,
Just wanted to confirm the r372 saves all the parameters with the Dimu installed.
The hud spins, but with the params.txt from Jussi thats fixed.
The tare command works!

Cheers,

Ray
Astudillo
 
Posts: 139
Joined: Thu Apr 25, 2013 8:23 am
Location: Amsterdam, The Netherlands

PreviousNext

Return to AQ6 +DIMU +CAN

Who is online

Users browsing this forum: No registered users and 1 guest

cron