Unable to write parameters to ROM after DIMU upgrade

Info & Discussions about good ole AQ6, taken to the next level.

r368 Can't save parameters

Postby SuperSharpShooter » Tue Apr 01, 2014 9:02 am

I've just installed a DIMU and flashed the DIMU version of r368, but after transmitting and writing parameters to ROM, when I repower the board, the parameters haven't changed from their initial values.

Config_version = 125. I've tried setting it to 0 and rebooting, but it does the same as trying to save anything else and comes back with default params.

Anyone know where I'm going wrong?

Edit: just tried r357 and can update parameters.
-Glenn
SuperSharpShooter
 
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: r368 Can't save parameters

Postby SuperSharpShooter » Tue Apr 01, 2014 9:37 am

Next problem... I connect using QGC, and I see the HUD spinning. Sometimes it will keep going, other times it will freeze, and the diagnostic telemtry shows 'nan' as the values for a bunch of things. All of the values that have numbers are actively changing.

Image

I've tried the tare function. If the HUD stays active without the nan issue, then I can level successfully, but after a reboot, the HUD is back to spinning, and i get a message in the bootup log 'DIMU: cannot read EEPROM parameters!'


Edit: I've just tried pulling the DIMU off and remounting it in the socket, and it looks to be behaving for now...
-Glenn
SuperSharpShooter
 
Posts: 276
Joined: Sat Jan 12, 2013 9:44 pm

Re: r368 Can't save parameters

Postby JussiH » Tue Apr 01, 2014 11:10 am

I have just posted a set of default IMU params, that will make your DIMU´s act sane:

viewtopic.php?f=42&t=3039&start=20
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Tue Apr 01, 2014 7:38 pm

Hi,

just upgraded to DIMU and flashed the board to firmware aqv7.0.r368.b1697-hwv6.0-dimu1.1.hex (downloaded form here ftp://ftp.autoquad.org/3/334693_22529/a ... erimental/).
SANY0088.JPG

SANY0091.JPG

SANY0092.JPG


Problem:
When changing ANY parameter (i.e. radio type) and writing it to ROM nothing seems to be written since all parameters were on their default settings after power-cycling the board. I'm working with QGC V1.3.0 (FTDI connection to AQ6) on OS X.

So: any advice how to proceed??
Joerg
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby Jdmagoo » Tue Apr 01, 2014 8:40 pm

aBUGSworstnightmare wrote:Hi,

just upgraded to DIMU and flashed the board to firmware aqv7.0.r368.b1697-hwv6.0-dimu1.1.hex (downloaded form here ftp://ftp.autoquad.org/3/334693_22529/a ... erimental/).
SANY0088.JPG

SANY0091.JPG

SANY0092.JPG


Problem:
When changing ANY parameter (i.e. radio type) and writing it to ROM nothing seems to be written since all parameters were on their default settings after power-cycling the board. I'm working with QGC V1.3.0 (FTDI connection to AQ6) on OS X.

So: any advice how to proceed??
Joerg


Hi there,

Looks like it might be a common problem. Check out the first post here:

viewtopic.php?f=31&t=3068
Jdmagoo
 
Posts: 485
Joined: Sun Feb 17, 2013 8:35 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby sandmen » Tue Apr 01, 2014 9:02 pm

Did a reset to default parameter help?
Last edited by sandmen on Tue Apr 01, 2014 9:45 pm, edited 1 time in total.
sandmen
 
Posts: 997
Joined: Fri Jun 22, 2012 7:25 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby kinderkram » Tue Apr 01, 2014 9:44 pm

Jdmagoo wrote:Looks like it might be a common problem.

Yes, that´s why I merged your thread with Joergs since it´s more a common DIMU prob.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Wed Apr 02, 2014 7:31 am

Hey guys,

well ... a 'reset to default' - as described in the wiki http://autoquad.org/wiki/wiki/autoquad- ... arameters/ - didn't change anything for me!

I've changed CONFIG-->CONFIG_VERSION 125 to CONFIG_VERSION 0, TRANSMIT-->WRITEtoROM --> reboot the board (power cycling or Reset button) and hit REFRESH. Nothing changed! All Parameters were as before (means CONFIG_VERSION is still 125). Changed the mixer, radio type, ... same picture for each parameter.
config_parmto0.tiff
params after flashing new firmware

config_parmto0-2.tiff
CONFIG_VERSION and RADIO_TYPE changed

config_parmto0-3.tiff
Parameters after reboot

console.tiff
Messages on CONSOLE - pls notice the 'DIMU: cannot read EEPROM parameters!'
console.tiff (120.85 KiB) Viewed 4098 times


I've also created a PARAMS.TXT file with only
Code: Select all
#define CONFIG_VERSION 0

rebooted the AQ and ended with the same result: NOTHING CHANGED!

So: How to do a factory reset for getting rid of an old parameter set?
And: What is the root course here!

READROM fails.tiff
EDIT: Read ROM also fails!
READROM fails.tiff (131.79 KiB) Viewed 4092 times


Joerg
aBUGSworstnightmare
Attachments
PARAMS.TXT
(24 Bytes) Downloaded 207 times
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Unable to write parameters to ROM after DIMU upgrade

Postby sandmen » Wed Apr 02, 2014 7:45 am

1. connect the board
2. power on
3. connect the qgc
4. open "serial console"
4. edit Radio selection
5. use store to AQ button, and select store into ROM on this dialog
6. press reset button on the fc
7. post log here.
sandmen
 
Posts: 997
Joined: Fri Jun 22, 2012 7:25 am

Re: Unable to write parameters to ROM after DIMU upgrade

Postby aBUGSworstnightmare » Wed Apr 02, 2014 8:08 am

Hi,

when talking about 'serial console' I think you're speaking of about the 'Communication Console'.

This is what I end up when doing as requested (as long as it's available in the communictaion console windows). Change radio type to Spektrum 10Bit.

Link serial port /dev/tty.SLAB_USBtoUART is connected.
(MAV 003) SUCCESS: Executed CMD: 245
(MAV 003) Mavlink init
(MAV 003) ADC task started
(MAV 003) Supervisor task started
(MAV 003) filer: created new session [8]
(MAV 003) DIMU: cannot read EEPROM parameters!
(MAV 003) Battery cells: 2
(MAV 003) Radio init
(MAV 003) WARNING: Invalid radio type!
(MAV 003) GPS init
(MAV 003) Nav init
(MAV 003) Command interface init
(MAV 003) Motors init
(MAV 003) Control init
(MAV 003) Control task started
(MAV 003) Mavlink SYS ID: 3
(MAV 003) AQ FW ver: 7.0 - EXPR rev368 b1697, HW ver: 6 rev0
(MAV 003) Disarmed
(MAV 003) Initialization complete, READY.

I've also checked HEX but I can't see any additional data. Pls notice: this is QGC V1.3.0 on OS X 10.9.2 (might be of interest).
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Next

Return to AQ6 +DIMU +CAN

Who is online

Users browsing this forum: No registered users and 3 guests

cron