M4 tries to make backflip

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

M4 tries to make backflip

Postby valintinr » Tue Nov 01, 2016 10:57 am

Hello everyone,
After some testing with ext ESC I decided to build microcoper similar to Ladybird.
Motors - 8520, battery - 1S 450Mah, frame - lantian 110, radio - frsky xsr (ppm).
I reset settings to default and configured radio and motors, all other parametres keep unchanged. I didn't do any PID/Quatos tuning.
When tried to take off my quad maked backflip. I tried few times and all the times same behaviour.
I convinced that even with default parametres should be at least some fly even unstable but not flip during take off.
Maybe someone can advise what I'm doing wrong.

Parametres - https://files.tangram.biz/index.php/s/iUJPg6z1jpJdnFy
Video1 - https://files.tangram.biz/index.php/s/nSOqTVdaK7YZmqm
Video2 - https://files.tangram.biz/index.php/s/CfqAiYoxBgpRpqC
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 tries to make backflip

Postby LPR » Wed Nov 02, 2016 2:20 am

For me when this happens it means that I did something wrong.
You have the motors in the wrong order.
The FC board is not rotated to the right position.

I would hold the little copter in my hand and with the motor running above an idle tilt the copter and see if the motors change speeds as they should.

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: M4 tries to make backflip

Postby aBUGSworstnightmare » Wed Nov 02, 2016 2:56 am

valintinr wrote:Hello everyone,
After some testing with ext ESC I decided to build microcoper similar to Ladybird.
Motors - 8520, battery - 1S 450Mah, frame - lantian 110, radio - frsky xsr (ppm).
I reset settings to default and configured radio and motors, all other parametres keep unchanged. I didn't do any PID/Quatos tuning.
When tried to take off my quad maked backflip. I tried few times and all the times same behaviour.
I convinced that even with default parametres should be at least some fly even unstable but not flip during take off.
Maybe someone can advise what I'm doing wrong.

Parametres - https://files.tangram.biz/index.php/s/iUJPg6z1jpJdnFy
Video1 - https://files.tangram.biz/index.php/s/nSOqTVdaK7YZmqm
Video2 - https://files.tangram.biz/index.php/s/CfqAiYoxBgpRpqC


Change all Motors to CAN Protokoll and then switch One after the other to PWM, arm the quad and Test the motor position and orientation. You will figure out which One ja wrong quite easy/fast
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: M4 tries to make backflip

Postby valintinr » Wed Nov 02, 2016 6:55 am

All motors in the correct position and right orientation. Actually I checked this few time before but did it again. Board installed right - forward ext radio.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 tries to make backflip

Postby bluuu » Wed Nov 02, 2016 8:31 am

can't be right if want to do the backflip

post some pics with your quad and mark motor numbers
mixer settings will be useful too for diagnose
bluuu
 
Posts: 1339
Joined: Mon Oct 29, 2012 8:02 pm
Location: Poland, Silesia

Re: M4 tries to make backflip

Postby valintinr » Wed Nov 02, 2016 10:48 am

valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 tries to make backflip

Postby JussiH » Wed Nov 02, 2016 11:19 am

Your motor Min and Max is for a Brushless motor on an external ESC. Brushed motors have a range of 0-1050uS Pulse width

Code: Select all
Your settings (For a external ESC and BL motor)

MOT_START                        1125
MOT_ARM                         975
MOT_MAX                        1950
MOT_MIN                        1000

Use this for Brushed motors:
MOT_START                           0
MOT_ARM                              0
MOT_MIN                              0
MOT_MAX                              1050



Is your build a Plus-quad, or is the board mounted with the STM32 facing up and arm 1 facing forward. If not, your IMO_ROTATE and IMU_FLIP params are wrong.

Are you using Quatos or PID? If using Quatos, you need Tr1 and Tr2 params.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: M4 tries to make backflip

Postby valintinr » Wed Nov 02, 2016 12:28 pm

JussiH wrote:Your motor Min and Max is for a Brushless motor on an external ESC. Brushed motors have a range of 0-1050uS Pulse width

Code: Select all
Your settings (For a external ESC and BL motor)

MOT_START                        1125
MOT_ARM                         975
MOT_MAX                        1950
MOT_MIN                        1000

Use this for Brushed motors:
MOT_START                           0
MOT_ARM                              0
MOT_MIN                              0
MOT_MAX                              1050



Is your build a Plus-quad, or is the board mounted with the STM32 facing up and arm 1 facing forward. If not, your IMO_ROTATE and IMU_FLIP params are wrong.

Are you using Quatos or PID? If using Quatos, you need Tr1 and Tr2 params.

Thank you, I test new values today.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 tries to make backflip

Postby LPR » Wed Nov 02, 2016 12:53 pm

For default parameters I used the "LadyBird V2 configuration" file in the wiki and I found that my Ladybird quad flies quite well with those parameters.

http://autoquad.org/wiki/wiki/building- ... dybird-v2/

CTRL_FACT_THRO 0.800000011921
CTRL_MAN_YAW_RT 180

IMU_ROT -135
IMU_FLIP 1

MOT_START 0
MOT_ARM 0
MOT_FRAME 0
MOT_MIN 0
MOT_MAX 1050

MOT_PWRD_01_P 5.79595708847
MOT_PWRD_01_R 5.79595708847
MOT_PWRD_01_T 1
MOT_PWRD_01_Y -0.25
MOT_PWRD_02_P 5.79595708847
MOT_PWRD_02_R -5.79595708847
MOT_PWRD_02_T 1
MOT_PWRD_02_Y 0.25
MOT_PWRD_03_P -5.79595708847
MOT_PWRD_03_R -5.79595708847
MOT_PWRD_03_T 1
MOT_PWRD_03_Y -0.25
MOT_PWRD_04_P -5.79595708847
MOT_PWRD_04_R 5.79595708847
MOT_PWRD_04_T 1
MOT_PWRD_04_Y 0.25

MOT_VALUE2T_A1 2.46399998665
MOT_VALUE2T_A2 0.507000029087
MOT_VALUE_SCAL 3.5

NAV_ALT_POS_OM 1
NAV_ALT_POS_PM 1

QUATOS_AM1 -8
QUATOS_AM2 -50

QUATOS_L1_K1 18.6000003815
QUATOS_MAX_OUT 1.5

QUATOS_J_PITCH 4.09999993281e-05
QUATOS_J_ROLL 4.09999993281e-05
QUATOS_J_YAW 7.89999976405e-05


QUATOS_MM_P01 0.0430000014603
QUATOS_MM_P02 0.0430000014603
QUATOS_MM_P03 -0.0430000014603
QUATOS_MM_P04 -0.0430000014603

QUATOS_MM_R01 0.0430000014603
QUATOS_MM_R02 -0.0430000014603
QUATOS_MM_R03 -0.0430000014603
QUATOS_MM_R04 0.0430000014603

QUATOS_MM_Y01 -1
QUATOS_MM_Y02 1
QUATOS_MM_Y03 -1
QUATOS_MM_Y04 1

QUATOS_M_TLT_RT 1.5
QUATOS_M_YAW_RT 1.5
QUATOS_PROP_K1 200

SPVR_LOW_BAT1 3.11999988556
SPVR_LOW_BAT2 3.11999988556
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: M4 tries to make backflip

Postby valintinr » Wed Nov 02, 2016 6:56 pm

So I changed IMU_FLIP to 1 and fixed MOT_MIN/MAX/ARM/START and bird take off!!!
Im pretty happy and now time to tunig and I hope parametres would similar to ladybird.

P.S About MOT_MIN/MAX/ARM/START - as I mentioned in the first message I reset setting to default so thats why this setting wasn't right.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Next

Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 7 guests

cron