M4 with ext ESC

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

M4 with ext ESC

Postby valintinr » Mon Oct 10, 2016 10:45 am

Hello,
Im new in autoquad world but I decided to try it.
I bought M4 but forgot N4 exp board.

Installed on frame, desoldered EXP pads and soldered wires directly to pads #J2.7, J2.6, J2.10, J1.10 and wired signal wire from ESC (emax nano 12A flashed with BLHeli) to them and GND wire from ESC's to VUSB GND.
I also wired 5V from PDB to M4 VUSB. ESC's wired to PDB too. They was working fine with another flight controller.
Images - IMG_*
https://www.dropbox.com/s/2p6w3xrj8zn0l ... 1.jpg?dl=0
https://www.dropbox.com/s/k0upsnzf4y1yo ... 2.jpg?dl=0
https://www.dropbox.com/s/t637jmpl7a13w ... 8.jpg?dl=0
https://www.dropbox.com/s/lhyx82ahrpg0s ... 5.jpg?dl=0
Quad and wires looks a bit ugly but I will buy N4 and fix them.

Some settings on 1-3.png.
https://www.dropbox.com/s/v28qnfg0gtdl4yp/1.png?dl=0
https://www.dropbox.com/s/azsg7ssm2m53qzw/2.png?dl=0
https://www.dropbox.com/s/93cu9kf8hng5n8g/3.png?dl=0
After installing M4 I flashed It with latest firmware with ext_esc. Now I have some issues:
1. Flight mode not changed via 3pos switch (5.png - https://www.dropbox.com/s/1zex5auhxg25na1/5.png?dl=0)
2. Can't ARM (4.png - https://www.dropbox.com/s/ceomxnzhp5tazjj/4.png?dl=0)
3. Seems ESC's not initializing properly. When I used them with another FC after power ON I heared 2 grouped beeps - first one after power ON and second few beeps after few second. Ther first and the second rings are different. Now when I powering them I hear start beeps and after few second same beeps.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 with ext ESC

Postby Max » Mon Oct 10, 2016 7:42 pm

Welcome to AQ and the forums!

You should use a non-Quatos firmware, or set it up properly for Quatos (which is a bit more involved than PID controller). The old Quatos firmware version requires using ESC32s, hence the ESC init errors you're seeing at startup.

The ESCs won't arm until AQ itself is armed. Until that time, some ESCs will beep an "error" condition to indicate that they're not armed. This is normal.

You cannot switch flight modes until after AQ is armed. From your radio telemetry screenshot, this looks OK.

You can get newer (latest) firmware directly from the FTP site: ftp://ftp.autoquad.org/3/334693_22529/a ... tegration/ and see the changes list for details. This version allows switching between Quatos/PID controller and external/internal ESCs via settings, so just use the version which matches your AQ board (eg. board-8.6-quatos folder). This Quatos version can also be used with any decent ESC.

HTH,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: M4 with ext ESC

Postby valintinr » Tue Oct 11, 2016 9:52 pm

Thank you for your advices.
I decided to try m4 with quatos and brushed motors fitst like ladybird frame or similar. After that i return to ext ESC.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 with ext ESC

Postby valintinr » Wed Oct 12, 2016 11:15 am

Also please advice about ext headers:
http://www.newark.com/samtec/ftsh-105-0 ... pd-mi-alte
http://www.newark.com/samtec/clp-105-02 ... pd-mi-acce
They would be suitable for M4 board and for DIY exp board? Seems they should but asking to ensure that I'm right.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 with ext ESC

Postby JussiH » Wed Oct 12, 2016 3:43 pm

valintinr wrote:Also please advice about ext headers:
http://www.newark.com/samtec/ftsh-105-0 ... pd-mi-alte
http://www.newark.com/samtec/clp-105-02 ... pd-mi-acce
They would be suitable for M4 board and for DIY exp board? Seems they should but asking to ensure that I'm right.


Yep, they are the specified connector for expansion boards.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: M4 with ext ESC

Postby valintinr » Fri Oct 14, 2016 9:57 am

Thanks
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 with ext ESC

Postby valintinr » Thu Oct 20, 2016 7:54 pm

Hi again,
I bought small frame similar to ladybird, 8520 brushed motors and 450mah 1S battery.
After soldering + and - to Battery Port (according to wiki) and tried to turn on via button nothing happened, nothing. Baterry fully charged, via USB (and VUSB pads) board powering on. Now I tried to desolder power buttond and soldered jumper from UTP cable and same behavior - nothing changed after connecting battery. No short circut on battery port - I chacked and button pads shorted.
Some photos:
https://www.dropbox.com/s/sj6ibc9vyxj2g ... 1.jpg?dl=0
https://www.dropbox.com/s/9fqlfagtbisdc ... 7.jpg?dl=0
https://www.dropbox.com/s/v28qnfg0gtdl4yp/1.png?dl=0
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am

Re: M4 with ext ESC

Postby bluuu » Thu Oct 20, 2016 8:55 pm

power button is a "tact" button so you can't make there a short
bluuu
 
Posts: 1339
Joined: Mon Oct 29, 2012 8:02 pm
Location: Poland, Silesia

Re: M4 with ext ESC

Postby valintinr » Fri Oct 21, 2016 6:01 am

You right, i forgot that button is tact (how? :))
I removed short and after pluggin battery and shorting once board become work. So seems something wrong was with button, I will buy new one then.
valintinr
 
Posts: 20
Joined: Mon Oct 10, 2016 10:24 am


Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 4 guests