[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - USB connection problem

USB connection problem

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

USB connection problem

Postby luckpl » Tue Apr 19, 2016 11:14 am

Hi everyone,
I have some problems on QGC connection.

When I use the USB to connect the QGC, at first, everything is normal, I can see the artificial horizon move and get telemetry data. But when I save the modified parameters to permanent memory (write to flash), sometimes it can save successfully, but most of the times the MAV lost connection with QGC. Below are some pictures about the problem.

This is my QGC mavlink setting:
Image
This is the Tip box when connection gets lost:
Image
Need help :) :)
luckpl
 
Posts: 11
Joined: Tue Nov 24, 2015 7:49 am

Re: USB connection problem

Postby Mullet » Fri Apr 22, 2016 12:42 pm

Two things:

Have you tried using a different USB cable? Some USB cables that I have strangely can't keep a good connection. Jiggle the cable around and see if you lose connection.

Have you tried using a different computer?

Hopefully one of the two fixes your issue.
Mullet
 
Posts: 181
Joined: Sun Dec 28, 2014 5:56 am
Location: Fairfield County Connecticut

Re: USB connection problem

Postby luckpl » Sat Apr 23, 2016 2:54 am

thanks for your suggestion,Mullet. :)
I have tried a different USB cable and a different computer,but the problem still persists. :?
I don't think the USB or USB drive has problem,as it is normal when I use the USB to update the firmware,so I suspect that the QGC has some bugs.
luckpl
 
Posts: 11
Joined: Tue Nov 24, 2015 7:49 am

Re: USB connection problem

Postby Max » Sat Apr 23, 2016 4:20 am

Do the LEDs on the M4 keep blinking when this happens? Can you reconnect to it, or does it always require restarting the M4? Do you have the M4 powered some other way besides the USB cable? Which firmware and QGC versions?

After the disconnect happens, you can check to see if that COM port is still available on the system (eg. in Device Manager). I'm guessing that it is not, which is why QGC reports errors. I'm also guessing that it is the M4 which has a problem, perhaps crashing when trying to write to flash RAM.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: USB connection problem

Postby luckpl » Sat Apr 23, 2016 11:19 am

my mistake, i thought it is AQ6 at first :lol: :lol:
Last edited by luckpl on Sun Apr 24, 2016 1:16 pm, edited 1 time in total.
luckpl
 
Posts: 11
Joined: Tue Nov 24, 2015 7:49 am

Re: USB connection problem

Postby aBUGSworstnightmare » Sat Apr 23, 2016 11:40 am

aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: USB connection problem

Postby Max » Sat Apr 23, 2016 7:55 pm

Yea, what are you trying to, and how do you plug a USB cable into an AQ6?

How is the QGC screenshot showing an AQ/MSC connection?

:?

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: USB connection problem

Postby luckpl » Sun Apr 24, 2016 8:29 am

Is my board M4? My god!! I am confused :shock:
luckpl
 
Posts: 11
Joined: Tue Nov 24, 2015 7:49 am

Re: USB connection problem

Postby aBUGSworstnightmare » Sun Apr 24, 2016 12:26 pm

aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: USB connection problem

Postby luckpl » Sun Apr 24, 2016 1:04 pm

Oh,it is M4.
I got it from my brother, he used it at first, maybe i need to read the Wiki, I think I miss something important. :D
luckpl
 
Posts: 11
Joined: Tue Nov 24, 2015 7:49 am

Next

Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 2 guests

cron