[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - Desperately need help analysing log files!!

Desperately need help analysing log files!!

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

Desperately need help analysing log files!!

Postby whizz101 » Sun Apr 17, 2016 10:12 am

Hello all !

I am having some problems with my large hexa copter that i recently changed the FC from AQ6 to an M4.

I am flying;
a 8.5kg hexacopter,
tiger motor U5 motors
tiger motor 40 amp pro esc's
M4 V2 with an adapter board from Joerg, very similar to the N4 (with extra connections to motor ports 1-4)
AQ FW; v7.0-EXPR rev 445 b1851 HW: v8.6 (One of Mennos Hott releases)
Only calibrated using "tare" and compass calibration.

here is my parameters file-
pro 6 parameters M4.txt
(15.27 KiB) Downloaded 654 times

20160417_134855.jpg

20160417_134931.jpg


Generally the hexa flies fantastically. Return to home, postion hold ect all work perfectly. The accuracy in mission flights seems improved over the AQ6.

However i have a serious problem, in about 1 in 5 flights, with no warning i get a loss of control and she tries to fly away, always pitching forward. At this point all i can do is cut throttle.

From looking at the logs i can identify the same problem on 4 flights.

If you look at this log from one of my crashes;
park crash.jpg
Park crash


You can see from the motor outputs, all looks OK until the last few seconds then the motor outputs go crazy. You can also see that i have no "stick" input.

Here you can see that vibrations are not the problem,
park crash vibration 1.jpg




Here is the crash from the camera on the gimbal

[vimeo]https://vimeo.com/163112560[/vimeo]

You can see that i finish my rotation and the craft has just about stopped, when suddenly....she tries to fly off!

I have made a folder with the logs from all four of these incidents. They are available here;

https://www.dropbox.com/sh/z23bjgaxiwry ... AEFza?dl=0

In all four incidents you can see the same problem in the motor outputs. All seems normal then go's crazy. The really worrying part is that this has happened in manual as well as position hold.
First crash.jpg



In all the flights where i have this problem, the logs are the same. I can clearly see that there is a problem from looking at the motor outputs. However i am at a loss to the cause of this. I had originally suspected it to be an issue with compass calibration, but multiple re- calibrations have not solved the issue.

This problem is really sending me crazy. I am suppose to be working all this week, but until i can understand and fix this problem I have had to tell my clients that i am "grounded", which is a disaster as we are shooting a ski film and there is only 2 weeks left of the season!

I do not understand why i can get multiple perfect flights, and then suddenly a problem.

I hope that to someone with a deeper understanding of autoquad that the answer to my problem is in the logs. But where do i look and what do the graphs mean?

Any help would be very much appriciated! If there is some one out there that i can pay to do a few hours analysing my logs and offer solutions, i have no problem paying for some one's time!

In the meantime, I am going to switch my flight control to a new M4-N4 from flyduino, and update the firmware to one of max's new builds and cross my fingers that the problem goes away.

Thanks for listning......

Tristan
Last edited by whizz101 on Sun Apr 17, 2016 1:16 pm, edited 1 time in total.
whizz101
 
Posts: 83
Joined: Thu Oct 16, 2014 9:00 pm

Re: Desperately need help analysing log files!!

Postby Simson » Sun Apr 17, 2016 1:02 pm

First of all, I would change to a newer Firmware Version.
The one you are using is quite old.
Here you can find newer firmwares :

Acro mode! And more...
viewtopic.php?t=4821


Are you using a Groundplate underneath the GPS Antenna?
To get good GPS /Glonass Reception you should have a Glonass Antenna.
Taoglas is one of the best ones.
Last edited by Simson on Sun Apr 17, 2016 1:21 pm, edited 1 time in total.
Simson
 
Posts: 62
Joined: Tue Jan 20, 2015 1:07 pm

Re: Desperately need help analysing log files!!

Postby whizz101 » Sun Apr 17, 2016 1:19 pm

hi, yes i'm updating firmware and changing to another M4.

And yes i use a large groundplane and get excellent gps, i have recorded sub 30cm hACC regularly.
20160417_142006.jpg
whizz101
 
Posts: 83
Joined: Thu Oct 16, 2014 9:00 pm

Re: Desperately need help analysing log files!!

Postby Max » Sun Apr 17, 2016 1:26 pm

Hi Tristan,

How is the temperature of the board while you're flying? Can you recreate the problem if you just let the 'copter sit long enough while powered and on? I'm wondering if you'll see the IMU crashing/overheating (which would make the GCS HUD go "nuts").

What kind of voltage are you feeding to Jörg's adapter board? The one I have starts getting pretty hot once input is > 7-8V or. Could just be this one... an earlier prototype I think. At 12V I can barely touch it after a couple minutes.

Can you come up with any similarities between the crashes? Amount of time, or location, weather, flying "style"... never know where a clue may lie. The less "random" it seems, the easier it will be to solve.

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Desperately need help analysing log files!!

Postby whizz101 » Sun Apr 17, 2016 2:39 pm

Attachments
temp, park crash.jpg
Last edited by whizz101 on Sun Apr 17, 2016 3:01 pm, edited 1 time in total.
whizz101
 
Posts: 83
Joined: Thu Oct 16, 2014 9:00 pm

Re: Desperately need help analysing log files!!

Postby JussiH » Sun Apr 17, 2016 2:44 pm

Hott has been suspected of causing "bad things" - far as I know there has been similar reports on the German forums.

I dont personally use Hott, so I havent been able to verify it. I can tell you that I have built several crafts based on official R445 and never had any problems like what you are describing. I would suggest trying an official build of the same version 445 to see if that solves the problem.

Max is right that your temp is pretty high. Up to 55 degrees in the first log - the last 3 seems more normal. That could be part of the problem. If that is the temp of the IMU, then probably the temp of the expander is even higher.

Otherwise, I dont find any immediate problems looking at the logs. Try changing to an official release and see if that cures it.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Desperately need help analysing log files!!

Postby whizz101 » Sun Apr 17, 2016 3:19 pm

whizz101
 
Posts: 83
Joined: Thu Oct 16, 2014 9:00 pm

Re: Desperately need help analysing log files!!

Postby JussiH » Sun Apr 17, 2016 3:59 pm

As I said, 445 has been stable for me, but its quite old, and you might want to check out some of Max´s recent "next" releases.

Im sure that we will soon see a horisontal limiter in the "next" branch
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Desperately need help analysing log files!!

Postby aBUGSworstnightmare » Sun Apr 17, 2016 4:52 pm

aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Desperately need help analysing log files!!

Postby whizz101 » Mon Apr 18, 2016 5:28 pm

Hi Joerg,

Thanks for your input. I can confirm that the Hott telemetry was off.

I have now changed firmware and hardware, and about to test fly....
whizz101
 
Posts: 83
Joined: Thu Oct 16, 2014 9:00 pm

Next

Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 5 guests

cron