[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - M4/USB/Win device not recognized [solved]

M4/USB/Win device not recognized [solved]

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

M4/USB/Win device not recognized [solved]

Postby Max » Tue Dec 08, 2015 5:51 pm

Anyone seen/fixed this problem?

I recently built a new workstation PC with common current-era (2015) components (Intel X99 chipset, Xeon Haswell CPU, etc.). The OS install hasn't changed (I just moved the system drives). On the old PC everything worked fine...

Now when I plug in an M4, Windows can't load the drivers properly, unless I first power the M4 externally. This happens with r3, r4, and v2 boards I have (r26 removed on the v2).

Actually just now I narrowed it down to only the ports which are controlled directly by the Intel chipset (both USB 2 and 3). There are some other USB3 ports on the board which are managed by a separate onboard controller and drivers (ASUS/ASMedia), and these all work fine (luckily there are 10 of them, but they're all in the back :) ).

I suspect it is some BIOS or driver setting... anyone know before I try to chase it down?

Thanks,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: M4/USB/Win device not recognized unless externally power

Postby kinderkram » Tue Dec 08, 2015 6:15 pm

Sorry, can´t offer a simple solution but have some questions:
You´re using Win7? And you only moved the hds to the new pc?
Did you install the drivers for the new hw by hand or did you let the OS do it automatically?
In the device manager, when you display "hidden devices" do any devices show up in the USB contoller section?

There were reports of problems w/ Haswell related to USB3 in late summer - but Intel seems to have fixed them.
In such a case I´d remove all USB contoller related entries and manually update them with the latest drivers from the manufacturer, Intel - not ASUS.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: M4/USB/Win device not recognized unless externally power

Postby Max » Tue Dec 08, 2015 6:41 pm

Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: M4/USB/Win device not recognized unless externally power

Postby kinderkram » Tue Dec 08, 2015 11:42 pm

Have you tried external hubs on the said ports? I´d try powered/unpowered hubs to see if it at least detects the device then. The M4 obviously doesn´t trigger the port to become active ... somehow.

I only remember there was a slightly different problem with Intel USB3 chips:
viewtopic.php?f=40&t=4178

Maybe Intel didn´t completely remove the bugs of the Haswells. At least this should be solvable through driver updates.
Next year... :?
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: M4/USB/Win device not recognized unless externally power

Postby Max » Thu Mar 03, 2016 4:42 am

To update this, it was in fact solved by updated Intel USB3 drivers once I finally tracked them down (Intel's links were broken). Norbert, you were right all along. :oops: Or maybe the January version fixed it... who knows. The d-load works now.

https://downloadcenter.intel.com/downlo ... set-Family

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA


Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 3 guests