M4v2 via SBUS (Taranis) - ch. assignment problems

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Fri Dec 04, 2015 10:37 pm

Tried today to get my m4v2 configured, had it flying before with a Futaba transmitter with PPM, now it should work with my Taranis with x8r receiver via SBUS.

built an inverter using a BC848 SMD transistor, hooked up to 3.3 V , and works. But, in GCS, i have wrong channel assignment, doesnt match the transmitter settings. When i change ch 1-4 to a matching assignment, i cannot adjust throttle between 0 - 1400, range is -850 to +750.

I have no clue what is running wrong, any suggestions ?

e.g., normally ch1 would be throttle, but find it as pitch, Even yaw and roll are changed. When i change both setting, it´s crossed again between pitch and roll. When i puzzled the working assignment i have the throttla-range-problem.
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby LPR » Fri Dec 04, 2015 11:45 pm

Crizz

You can change any control to any channel with a Taranis. Look at online manuals or Youtude videos for the Taranis.

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Fri Dec 04, 2015 11:53 pm

Larry, i know that i can change the controls at the Taranis. The main thing is : why it works with external Spektrum module with the right assignment, but not when i use a FRskay x8r ?

I would guess it makes no difference if i swap the assignment in the transmitter to get the right order at the receiver - it only shifts the problem to another level, doesnt it ?
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Sat Dec 05, 2015 12:16 am

tried it, just for fun - and was right : he problem´s still the same, just with another channel-assignment now ( ch 3 instead of 2 )

Any proposals ?
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Max » Sat Dec 05, 2015 1:30 am

AQ expects typical Futaba order of channels when using SBus, A/E/T/R (or R/P/T/Y). Set it to that order in Taranis but then use default AQ channel assignments (1-4 respectively for T/R/P/Y). I know that doesn't make a lot of sense, but that's how it's coded in the firmware. You will possibly need to adjust the end-points and direction of channels on the Taranis Servos screen.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Sat Dec 05, 2015 9:08 am

Hi Max,

please believe me when i say that i already tried it, Okay, maybe i didnt see any little thing that causes this, but what makes me wonder is that it´s working with Futaba in PPM Mode, with Spektrum, but gives me the mentioned problem with SBus.

Its weekend now, so i will have a little more time in toto to have a closer look at it. Some things shouldnt be startet after work with a tired head ;)
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Sat Dec 05, 2015 1:54 pm

Found the reason and fixed the problem. Like i said, it was sitting in front of it.... defined the wrong input for the throttle stick. Used a mixing input named [thr] instead of using GAS as physical source. That´s all. :oops:

Meanwhile i figured that f/s action only can be excecuted when system is armed (makes sense).
(for anybody who wants to try at home : remember to remove your props in the first to avoidfrom risc of serious hazard and injury !)
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby kinderkram » Sat Dec 05, 2015 2:59 pm

Well, at least you found out. Good job!
I was also confused by the Taranis channel assignment in the first place - until I figured out.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: M4v2 via SBUS (Taranis) - ch. assignment problems

Postby Crizz » Sat Dec 05, 2015 4:17 pm

yep, what confused me most was that my problem didnt change with ch.-assignment, but today this helped me to check for the single steps in the transmitter where the channels are configurated. The Taranis is a real mighty tool, but in the beginning it can be a trap also ;)
Crizz
 
Posts: 211
Joined: Sat Aug 09, 2014 3:43 pm


Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 1 guest

cron