A4 M4+BLDC cant arm one esc

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

A4 M4+BLDC cant arm one esc

Postby brat002 » Fri Nov 27, 2015 7:16 am

Hi all.
I am building new quad-frame with M4 board+BLDC expansion board. After all wires was correctly connected and firmware was flashed i started tests. One motor+Kiss ESC 30a cant arm and spin. I tried to connect this motor in other ESC ports - it doe snot arm in any port. Although servo tester and receiver(when i connect wire from esc directly to PWM output) spins this motor.

What is wrong?
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby aBUGSworstnightmare » Fri Nov 27, 2015 11:51 am

brat002 wrote:Hi all.
I am building new quad-frame with M4 board+BLDC expansion board. After all wires was correctly connected and firmware was flashed i started tests. One motor+Kiss ESC 30a cant arm and spin. I tried to connect this motor in other ESC ports - it doe snot arm in any port. Although servo tester and receiver(when i connect wire from esc directly to PWM output) spins this motor.

What is wrong?


... o.k. once more: did you adjust ESC Settings on 'MISC SETTINGS' tab? They need to be adjusted when using other ESCs than ESC32Vx.

Used the ones below with KISS12A:
Arm: 1050
Min PWM: 1065
Starting PWM: 1110
Max PWM 1950
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Fri Nov 27, 2015 1:03 pm

Yes.
MOT_ARM 975
MOT_START 1150
MOT_MAX 1832
MOT_MIN 1148

This problem affects only one ESC+motor.

All ESC`s from one batch and works pretty good with servo tester.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby aBUGSworstnightmare » Fri Nov 27, 2015 1:36 pm

brat002 wrote:..
This problem affects only one ESC+motor.
All ESC`s from one batch and works pretty good with servo tester.
brat002 wrote:One motor+Kiss ESC 30a cant arm and spin. I tried to connect this motor in other ESC ports - it doe snot arm in any port. Although servo tester and receiver(when i connect wire from esc directly to PWM output) spins this motor.


Are all the ESCs calibrated to the same PWM Signal range (min/max settings)? Sounds strange indeed ...
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Fri Nov 27, 2015 6:54 pm

Yep. All ESCs calibrated.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Fri Nov 27, 2015 7:34 pm

attached some logs and params file.
I cant solve this problem. :(
Attachments
PARAMS.txt
(14.83 KiB) Downloaded 171 times
log.txt
(59.95 KiB) Downloaded 176 times
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Fri Nov 27, 2015 8:01 pm

I recalibrated ESCs with Mennos firmware. Nothing changed.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Sat Nov 28, 2015 11:12 pm

Today I performed some experiment. I soldered signal wire to backup pad on Kiss ESC and now it works. Very strange...
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: A4 M4+BLDC cant arm one esc

Postby kinderkram » Sat Nov 28, 2015 11:27 pm

Glad you found out!

So it looks like the KISS is having troubles on the primary PWM input. Strange...
Maybe you should send a message to Flyduino, so Felix can get the info.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: A4 M4+BLDC cant arm one esc

Postby brat002 » Sun Nov 29, 2015 9:32 pm

I cant take off. Frame has large oscilations, that can not be supressed with pid tuning. Does BLDC expansion board compatible with mennos firmware?
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Next

Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 5 guests

cron