problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Info and discussion about the autonomous Micro FC, suitable for nanos, micros and mini multirotors

problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Postby UncleF » Sun Nov 22, 2015 2:13 pm

Hi,

i have problems with a Spektrum DX6 an the Autoquad M4v2. I will use the internal CYRF-Receiver on the M4-Board.

- i use the firmware 7.1.1852-hwv8.6-quatos on the board
- Binding works with my Spektrum DX6, DSMX 22ms.
- the radio quality shows 2-3% in QGC... :-(
- and the channels "overlap"... :-(( Channel 1 (Gas) shows 100% in QGC when it in the middle position and when the gas stick goes over the middle position to the high position the channel 2 (Roll) is active. Same with other channels.
- the servo monitor in the transmitter shows the correct channels.

Whats wrong in my setup? Or is the Spektrum DX6 incompatible with the internal receiver on the autoquad m4v2?

The board works correctly with a Spektrum DX8 from a friend. I have no other hardware for testing...

Thanks for your answers!

UncleF


PS: Sorry for my bad english...
UncleF
 
Posts: 3
Joined: Sun Nov 22, 2015 1:41 pm

Re: problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Postby aBUGSworstnightmare » Sun Nov 22, 2015 2:37 pm

UncleF wrote:Hi,

i have problems with a Spektrum DX6 an the Autoquad M4v2. I will use the internal CYRF-Receiver on the M4-Board.

- i use the firmware 7.1.1852-hwv8.6-quatos on the board
- Binding works with my Spektrum DX6, DSMX 22ms.
- the radio quality shows 2-3% in QGC... :-(
- and the channels "overlap"... :-(( Channel 1 (Gas) shows 100% in QGC when it in the middle position and when the gas stick goes over the middle position to the high position the channel 2 (Roll) is active. Same with other channels.
- the servo monitor in the transmitter shows the correct channels.

Whats wrong in my setup? Or is the Spektrum DX6 incompatible with the internal receiver on the autoquad m4v2?

The board works correctly with a Spektrum DX8 from a friend. I have no other hardware for testing...

Thanks for your answers!

UncleF


PS: Sorry for my bad english...


Can you try with DSM2 as well? Also change frame rate to 11ms in case of DSMX and test again.

well, there are some reported incompatibilities with transmitters (http://autoquad.org/wiki/wiki/m4-microc ... o-options/), but never heard that a DX6 was affected.

I can see such effect with one of my old orange DSM2 sats when binding them to a DX10.

If internal receiver will not work for whatever reason you can still connect a Spektrum sat to the M4.
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Postby UncleF » Sun Nov 22, 2015 2:51 pm

Hi,

thanks for your answer.

I dont know how i should bind the transmitter in DSM2-Mode... nothing in the manual. I think, its depends on the receiver.

In the moment i have no spektrum receiver to test it as a external radio on the board. But i will build a small ladybird, the internal receiver were the best option.... ;)


Is it a generally problem with the new transmitters? DX6 ist the new model, the DX6i works, the DX8 also...
UncleF
 
Posts: 3
Joined: Sun Nov 22, 2015 1:41 pm

Re: problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Postby UncleF » Sun Nov 22, 2015 3:02 pm

Now, i have tested 2 different Spektrum DX6.

Both transmitters have the same problem with the internal CYRF-Receiver. I think, there are a general problem with the Spektrum DX6 and the AutoQuad M4v2......
UncleF
 
Posts: 3
Joined: Sun Nov 22, 2015 1:41 pm

Re: problems with Autoquad M4v2 and Spektrum DX6 (not DX6i!)

Postby aBUGSworstnightmare » Sun Nov 22, 2015 7:42 pm

UncleF wrote:Now, i have tested 2 different Spektrum DX6.

Both transmitters have the same problem with the internal CYRF-Receiver. I think, there are a general problem with the Spektrum DX6 and the AutoQuad M4v2......

http://www.spektrumrc.com/Products/Defa ... Id=SPM6700

Don't know your native language, but you can change this under 'SYSTEM SETUP/FRAME RATE'
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm


Return to AutoQuad M4 Micro Controller

Who is online

Users browsing this forum: No registered users and 2 guests

cron