Build TBS Disco modded to X8 AQ FC and ESC32

Post your build logs here

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby boriss » Tue Nov 20, 2012 1:52 am

okay i finally got one run with clean logs and the board coming out of the freezer. The reason seems to be the combo freezing up the board and the antistatic bag. If i use a normal plastic bag and the same components as usual things work. If the antistatic bag is used the Mag logs are not clean. I can't explaing it does this make any sense ?

Thanks

Boris
boriss
 
Posts: 204
Joined: Wed Aug 08, 2012 7:26 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby Max » Tue Nov 20, 2012 2:54 am

Glad you found the problem! We should probably put a warning in the docs about this...

The silver/metallic type ESD bags work by dissipating static electricity across the whole surface of the bag, like a Faraday cage. There could be small amounts of static generated as the board/air warms up, which are then spread out over a wide area around the AQ board, creating the mag interference. At least that's my theory... :)

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby boriss » Tue Nov 20, 2012 3:05 am

I have to give it one or two more runs to be really sure. But who would think that. Actually thought i am doing the board something good with that bag. But I guess not :)

Boris
boriss
 
Posts: 204
Joined: Wed Aug 08, 2012 7:26 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby boriss » Tue Nov 20, 2012 3:09 am

I think the best advice would be to before actually starting the freezing calibration procedure to do a short test log with every component that is added to the equation. Once in the dry run things work out go for the longer freeze it and logging action. I could have saved time there. Although not necessarily in my case if the Bag is really reacting in some strange way with temperature, than i wouldn't have noticed before.

Boris
boriss
 
Posts: 204
Joined: Wed Aug 08, 2012 7:26 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby bn999 » Tue Nov 20, 2012 4:24 pm

This whole thing sounds strange, but if it is truly the cause, I'm very glad it was discovered.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby Jessestr » Tue Nov 20, 2012 5:48 pm

I was going to use the anti static bags too.. Never used them since it was too small when the pinheaders were one. My new autoquad pcb is shipped.. Will test if my static bag does the same
Jessestr
 
Posts: 163
Joined: Sun Nov 04, 2012 3:43 am

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby kinderkram » Tue Nov 20, 2012 7:55 pm

boriss wrote:I think the best advice would be to before actually starting the freezing calibration procedure to do a short test log with every component that is added to the equation. Once in the dry run things work out go for the longer freeze it and logging action. I could have saved time there. Although not necessarily in my case if the Bag is really reacting in some strange way with temperature, than i wouldn't have noticed before.

Boris

Yep, will add a note to the Wiki.
A dry run will show if there's a problem with the board/sensors from the start.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby nikivan » Tue Nov 20, 2012 8:08 pm

I never had good results when using bags during static calibration. My take on that is that as the temperature raises the bag might expand or shift and create a disturbance. I've got much cleaner logs when using plastic container, witch small amount of rise on the bottom to absorb moisture.

I was also thinking perhaps it is a good idea to coat the board with polyurethane or silicone spray. This should not only eliminate spikes during static calibration, but perhaps even save your helicopter if flying in the morning when often there is condensation developing on every surface.
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby boriss » Wed Nov 21, 2012 6:33 am

Okay here the outcome. Not 100%, but better and i can only pinpoint it to the Antistatic bag in combo with a temp change.

Try with a normal plastic zip bag. Mags either at the beginning or at the end act out a little. But not comparable to the logs before with the anti-s.

Dry run with normal plastic bag no freezing action:

dryruninplastikbagmags.JPG
dryruninplastikbagmags.JPG (48.97 KiB) Viewed 3467 times


Freezing with normal plastic bag:

plastikbagmags.JPG
plastikbagmags.JPG (50.88 KiB) Viewed 3467 times


new box:

boxmagsup.JPG
boxmagsup.JPG (53.4 KiB) Viewed 3467 times



Bolts glued
newbox.JPG
newbox.JPG (88.03 KiB) Viewed 3467 times
to the bottom and a silica orgy.

still not perfect, to the end there seems to be noise but only in the case when it was frozen. Altough the dry runs wasn't that long.

Using this box now which is better for sure. Just have to figure now why to the end the mags do show noise again ;(
There is nothing switching on close by or any change in the environment that i am aware of.
boriss
 
Posts: 204
Joined: Wed Aug 08, 2012 7:26 pm

Re: Build TBS Disco modded to X8 AQ FC and ESC32

Postby boriss » Thu Nov 22, 2012 8:33 am

Guys I am just not hacking it !

Mags are better but they have noise either at the beginning or at the end.

Did a long dry run now. Happened by chance because i fell asleep. In the same spot I am doing another freezed logging try now again:

Out come of the long dry run, it was cold outside around 0

ACC horizonzal

LongtermACCsmall.jpg
LongtermACCsmall.jpg (66.33 KiB) Viewed 3441 times


https://www.dropbox.com/s/sck9h9pg0fd6q ... ermACC.JPG

Gyro Horizontal

longtermratesmall.jpg
longtermratesmall.jpg (72.6 KiB) Viewed 3441 times


https://www.dropbox.com/s/49kur2im2du05 ... rmrate.JPG

Mags Horizontal

longtermmagssmall.jpg
longtermmagssmall.jpg (69.86 KiB) Viewed 3441 times


https://www.dropbox.com/s/cfnxopfpbhav4 ... ssmall.jpg

Temps Horizontal

Longruntempsmall.jpg
Longruntempsmall.jpg (69.39 KiB) Viewed 3441 times


https://www.dropbox.com/s/7yqg3i6e2j2fd ... ntemps.JPG

At this point I really don't now what to do anymore ! The static bag certainly had an effect on the mags when the board came out of the freezer. Dry run no effect could be seen, mags clean. Now with the box beginning or end Mags act out slightly like in result before.

I have a second board here, since I got an replacement sent 4 weeks ago that only reached me a week ago and in the meantime we thought it might be lost (wasn't registered), so Paul shipped another one to me which i agreed on with him i am keeping to the end of the week, so if something is wrong with this board we don't have the hassle of sending back and forward again.

What should i conclude now. Is it my method could there be something with the board.

Thanks

Boris
boriss
 
Posts: 204
Joined: Wed Aug 08, 2012 7:26 pm

PreviousNext

Return to Build Logs

Who is online

Users browsing this forum: No registered users and 2 guests

cron