Default PIDs seem VERY high!?

The last Bastion to fine tune your FC matching your airframe & setup

Re: Default PIDs seem VERY high!?

Postby brat002 » Sat Jun 06, 2015 7:56 pm

I was posted file in comment before download/file.php?id=6608
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: Default PIDs seem VERY high!?

Postby brat002 » Sat Jun 06, 2015 8:20 pm

I calculated throttle facto=0.3. It looks like true or I am wrong with calculations? (total thrust ~4.8 KG) with AUW 1100g.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: Default PIDs seem VERY high!?

Postby brat002 » Thu Jun 11, 2015 4:01 pm

I did replace propellers and now M4 flies like a charm. Just fantastic position hold...
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: Default PIDs seem VERY high!?

Postby chschmid » Thu Jun 11, 2015 4:04 pm

Good to hear that you can enjoy the AQ experience now. :D

Cheers
Christof
chschmid
 
Posts: 1800
Joined: Wed Jul 11, 2012 7:41 pm
Location: Herrliberg, Switzerland

Re: Default PIDs seem VERY high!?

Postby aBUGSworstnightmare » Thu Jun 11, 2015 6:08 pm

Thumbs up! Let us see a video next..
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Default PIDs seem VERY high!?

Postby brat002 » Fri Jun 12, 2015 4:47 pm

https://plus.google.com/115088185602590 ... 2590362535
Any suggestions for tuning? I did rotate frame at start and you can see some drift.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: Default PIDs seem VERY high!?

Postby chschmid » Fri Jun 12, 2015 7:11 pm

What do you want to tune? It flies very nice.

Cheers
Christof
chschmid
 
Posts: 1800
Joined: Wed Jul 11, 2012 7:41 pm
Location: Herrliberg, Switzerland

Re: Default PIDs seem VERY high!?

Postby aBUGSworstnightmare » Fri Jun 12, 2015 7:15 pm

Yep, flies nice!
Please set home position, rotate craft by around 90deg (don't change home pos) and switch RTH. Want to see how it Yaws.

Let us have the parameters and the logs of that test (short video would be great too).
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Default PIDs seem VERY high!?

Postby brat002 » Sat Jun 13, 2015 9:53 pm

Problem with yaw drift was resolved by careful acc. calibration.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

Re: Default PIDs seem VERY high!?

Postby brat002 » Sun Jun 14, 2015 5:40 pm

Today i tested my current PIDS and settings by my big tester-engineer: https://plus.google.com/115088185602590 ... 2590362535
She love autoquad :)
Last edited by brat002 on Sun Jun 14, 2015 9:47 pm, edited 2 times in total.
brat002
 
Posts: 191
Joined: Tue Apr 21, 2015 10:35 pm

PreviousNext

Return to PID Tuning

Who is online

Users browsing this forum: No registered users and 3 guests

cron