Altitude hold not holding – always sinking!

The last Bastion to fine tune your FC matching your airframe & setup

Altitude hold not holding – always sinking!

Postby hogster » Wed Dec 24, 2014 6:04 pm

Hi everyone :)

I thought I'd bring this question into its own thread in the tuning section ...

My AQ-controlled X8 is flying quite well now that I have reduced the vibration being picked up by the AQ using vibration-damping grommets. Current vibration levels from my last flight here:

24-12-14 ACC plots.png
24-12-14 ACC plots


The problem is when activating the Position Hold mode the platform slowly sinks to the ground. The position hold bit works and can keep the platform in position even in a headwind ... but the altitude hold is non existent! Even if I've set the throttle correctly to maintain altitude in Manual mode, enabling Position Hold mode makes the platform sink slowly.

Curiously, the GPS_HEIGHT plot actually shows this slow descent – so the AQ knows the platform is sinking but it doesn't appear to be doing anything about it! You can see the three downward sloping lines here which coincide with me enabling Position Hold mode. After the last descent I decided it wasn't worth pursuing with the tests any further!

24-12-14 GPS_HEIGHT plot.png
24-12-14 GPS_HEIGHT plot


I tried adjusting the Navigation Altitude Position P and I values but they appeared to make no difference whatsoever. Do these only affect the Mission mode rather than just the Position Hold mode?

What parameters can I adjust to improve the altitude-hold performance?

Many thanks for your help!

David :)
hogster
 
Posts: 239
Joined: Tue Feb 11, 2014 8:59 am

Re: Altitude hold not holding – always sinking!

Postby LPR » Thu Dec 25, 2014 5:37 am

David

There's some info in the AQ wiki.

http://autoquad.org/wiki/wiki/configuri ... eshooting/

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: Altitude hold not holding – always sinking!

Postby hogster » Fri Dec 26, 2014 12:32 am

Thanks LPR, I hadn't even thought to look in the Wiki! :roll:

This seems most relevant:

I have a relatively heavy payload and my AQ cannot reach the target altitude .... Increase your altitude speed P slightly.

I was adjusting the Altitude Position before so I will try changing the speed this time. What do the Navigation Altitude Position PIDs (or PI!) control do you know?

Many thanks :)

David
hogster
 
Posts: 239
Joined: Tue Feb 11, 2014 8:59 am

Re: Altitude hold not holding – always sinking!

Postby aBUGSworstnightmare » Fri Dec 26, 2014 1:13 pm

Hi David,

Sounds like you need to increase NAV_ALT_SPEED_I
Joerg
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Altitude hold not holding – always sinking!

Postby hogster » Fri Dec 26, 2014 5:28 pm

Thanks for your reply Joerg :) I'm on holiday now but will certainly give this tweak a go when I'm back in January.

Thanks again! :)

David
hogster
 
Posts: 239
Joined: Tue Feb 11, 2014 8:59 am

Re: Altitude hold not holding – always sinking!

Postby hogster » Thu Mar 05, 2015 9:15 am

Hi Joerg,

Just to let you know I've finally tried your suggestion of increasing Nav Alt Speed I but it didn't really improve matters :(

Previously with the value set at 2.84, the craft would slowly and steadily descend when position hold was enabled. But as soon as I increased it to 3, 3.5 or 4, the descent would keep stopping and starting with the motors ramping up in speed to halt the descent, but then slowing down too much afterwards allowing the craft to start sinking again.

Should I try increasing the P value or do you think it's something to do with the Nav Alt Pos gains?

Many thanks for your help :)

David
hogster
 
Posts: 239
Joined: Tue Feb 11, 2014 8:59 am


Return to PID Tuning

Who is online

Users browsing this forum: No registered users and 4 guests

cron