Consistent spikes

Static, Dynamic, Log File Analysis, Troubleshooting

Consistent spikes

Postby KhoaNgo95 » Tue Jul 07, 2015 2:19 am

Hello everyone,
I've been trying to perform static calibration on the AutoQuad 6 board for the past week or two. First time around, I ran firmware aqv6.7.r224.b1400-rev1 and got solid results. After that, I put the DIMU on, running aqv7.1.1852-hwv6.1-dimu1.1 and try to get similar data. However, one of my gyro axis looks to be out of wack, and the mag data doesn't look too nice either. I would love to hear your suggestions about what I did wrong. Maybe the DIMU is defective? Anyone with a working DIMU would like to sell me one? Viacopter and Flyduino is out of stock again.

I am not leaning toward any reason concerning the thaw environment because I got good data for the 1st run with the analog IMU. I've also tried with and without the sandwich bag method, no difference. I've checked all solder joints and connections. I am thinking it may be because of condensation but I've tried the method of leaving it open in freezer, close sandwich bag and lid when ready, take out and thaw. Am I doing something wrong?


http://s8.postimg.org/x56usmtrn/009_Temp.png

http://s8.postimg.org/fmst43r5f/009_Acc.png

As you can see below, one axis of the gyro looks messed up. The spikes are almost exact through 4 trials.
http://s8.postimg.org/sgquxg4kz/009_Gyro.png

http://s8.postimg.org/63j4an3n7/009_Mag.png

http://s8.postimg.org/41imwe5o3/009_Rate.png
KhoaNgo95
 
Posts: 4
Joined: Thu Apr 23, 2015 7:55 pm

Re: Consistent spikes

Postby aBUGSworstnightmare » Tue Jul 07, 2015 6:26 am

Please use jpg-files when posting pics.
Sorry, but I can't see and of the posted images.
pics missing.jpg
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Consistent spikes

Postby kinderkram » Tue Jul 07, 2015 8:49 am

Hi KhoaNgo95, welcome to AutoQuad!

The reason for your images not showing up might be restrictions by the image hoster. PNGs shouldn´t be a problem here.

A better way to present images is to upload them as attachments and then place them inline.

I´ve converted the tags to simple links for now so we can see the images...

Norbert
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Consistent spikes

Postby KhoaNgo95 » Tue Jul 07, 2015 5:36 pm

I apologize for the image not displaying, I've reattached these on Imgur. They are all in this link
http://imgur.com/a/JHreh#2

After reviewing my first run with the analog IMU, it really doesn't look too great, but still a better than the DIMU gyro?
I've been checking my freezer and the board in there feels wet on the surface. Is it supposed to be dry sitting in there? Maybe my freezer is wacko?
This is the first run with AIMU
http://imgur.com/a/GHLGu#4
KhoaNgo95
 
Posts: 4
Joined: Thu Apr 23, 2015 7:55 pm

Re: Consistent spikes

Postby kinderkram » Tue Jul 07, 2015 11:24 pm

Yes, it should be as dry as possible in the box.
You could add a bag of rice or silicate to keep humidity low. And close the box before taking it out of the fridge.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am


Return to Calibration

Who is online

Users browsing this forum: No registered users and 6 guests