Page 1 of 4

Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 12:32 pm
by matti
Hi guys!

Just got my hands on fresh AQ with DIMU board. I got latest 6.7 stable FW installed. I've configured all radios and other things ready for first flight.

I'm trying to do onboard Tare and Mag. Calibration but in QGC options for both are greyed out and not selectable. Neither the stick inputs work. Inclination and declination is set.

Is there some prerequisite I'm missing?

Matti

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 3:23 pm
by JussiH
You need to get a more recent firmware that is DIMU enabled. I would suggest getting the latest nightly build from the FTP.

A new release candidate to encompass a lot of new additions will be announced shortly.

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 5:31 pm
by matti
JussiH wrote:You need to get a more recent firmware that is DIMU enabled. I would suggest getting the latest nightly build from the FTP.

A new release candidate to encompass a lot of new additions will be announced shortly.

Thanks Jussi. Looking at the nightly builds I found out the special versions for DIMU. As a new user I thought it would be safe to start from newest stable release. 6.7 was recognized correctly by QGC, but the newest nightly shows up as unknown. Also PID values are empty and trying to save settings to AQ will give long list of errors.

Maybe documentation should have some note about versions supporting DIMU?

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 6:12 pm
by kinderkram
Hi Matti,
welcome to AQ!
The fw for DIMU are cleasrly marked as such:
ftp://ftp.autoquad.org/3/334693_22529/a ... erimental/

Try r429: ftp://ftp.autoquad.org/3/334693_22529/a ... -dimu-1.1/

Norbert

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 7:16 pm
by matti
kinderkram wrote:Hi Matti,
welcome to AQ!
The fw for DIMU are cleasrly marked as such:
ftp://ftp.autoquad.org/3/334693_22529/a ... erimental/

Try r429: ftp://ftp.autoquad.org/3/334693_22529/a ... -dimu-1.1/

Norbert

Thanks Norbert! Rebooting my trusty old laptop solved that QGC problem. Now I got the latest nightly up and running. Some setup and I'm ready for first flight tomorrow! Next up I'm likely complaining about magnetic interference caused by my poor wiring. :D

Just to sum up my experience: I've been following AQ project for over a year now. After reading the documentation over and over again I still fell to that 6.7 stable trap as there is no note pointing out that DIMU is supported only in the experimental versions.

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Sun Oct 05, 2014 7:25 pm
by chschmid
Hi Matti

We know that our wiki is not up to date. We are hard working on it. It should be ready and up to date soon.
Meanwhile do as you did. Post in the forum and we help you to get airborn.

Cheers
Christof

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Mon Jan 26, 2015 8:07 am
by zhlearnaq
hello, anyone there? I am reading the calculation part, and i am confused:
(1)Do the Onboard Magnetic Calibration and Tare process should be done before static and dynamic data gathering?
(2)From the Documentation, i think they should be done first, but after reading the static and dynamic data gathering part, i am confused. Since before gathering datas, there are no other work. what should i do first and if do the tare first, should i save the parameters first and then use the saved parameters to do further data gathering?
Could anybody please to give me a suggestion? Thanks

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Mon Jan 26, 2015 10:40 am
by JussiH
No

The tare and Magnetic calibration is a standalone process. Just do these 2 and you should be ready for first takeoff.

You either do the tare/mag calib OR the the full process. Not both together.

In fact you can also do a combination to get the best of both worlds:

http://autoquad.org/wiki/wiki/configuri ... pensation/

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Tue Jan 27, 2015 5:49 am
by zhlearnaq
Thank you for your reply, i got another problem. When using dynamic datas to calculate the parameters(DIMU Calibration Without Temperature Compensation), some of my parameters are still to zero like those:
#define DEFAULT_IMU_GYO_SCAL_X +0.999545216316 // 0.000000049996 -0.000022464618
#define DEFAULT_IMU_GYO_SCAL_Y +1.000474821020 // 0.000000049997 +0.000023850621
#define DEFAULT_IMU_GYO_SCAL_Z +1.000331128890 // 0.000000049998 +0.000016456516
#define DEFAULT_IMU_GYO_ALGN_XY +0.000000000000 // +0.000000000000 +0.000000000000
#define DEFAULT_IMU_GYO_ALGN_XZ +0.000000000000 // +0.000000000000 +0.000000000000
#define DEFAULT_IMU_GYO_ALGN_YX +0.000000000000 // +0.000000000000 +0.000000000000
#define DEFAULT_IMU_GYO_ALGN_YZ +0.000000000000 // +0.000000000000 +0.000000000000
#define DEFAULT_IMU_GYO_ALGN_ZX +0.000000000000 // +0.000000000000 +0.000000000000
it must be not right. Anyone have ever come across such problems? What should i do?

Re: Unable to start Onboard Tare and Mag. Calibration

PostPosted: Tue Jan 27, 2015 9:24 am
by plexus
Hi zhlearnaq,
I get the same thing after testing that process in the wiki.
I believe something wrong in the tuto.

Alain