BT connection problem

Radio, Telemetry, FTDI/USB, ESCs, Motors, etc.

BT connection problem

Postby Altix » Sat Feb 21, 2015 9:57 am

I have a bunch of different BT modules, amongst them several cheap HC-06 from ebay as well as the module from Flyduino. After a lot of squeezing Google for a while, I got most problems solved with the exception of one:

All modules can be programmed via Putty (e.g. OK on AT command)
All modules are runnig on 57600 baud (I have an additional 433MHz telemetry which is running on that baud rate and shall be used alternatively)
All modules are set on "Parity None"
All modules can be used to programm an AQ6 or M4 via PC by the GCS without any problem
Only a single one is properly working with the android app (set to BT, 57600 baud), whereas the others refuse to build up a connection.

Does anybody have an idea about tthe magic command, that will make the other work together with the app?
Regards, Michael
Altix
 
Posts: 45
Joined: Tue Nov 25, 2014 6:54 am
Location: Heiligenhaus, Germany

Re: BT connection problem

Postby sandmen » Sat Feb 21, 2015 10:12 am

Is binding working, with all BT modules?
sandmen
 
Posts: 997
Joined: Fri Jun 22, 2012 7:25 am

Re: BT connection problem

Postby Altix » Sat Feb 21, 2015 10:42 am

Yes, with the BT dongle in my PC as well as with my smartphone (at least according to "Settings" after entering "1234")
Regards, Michael
Altix
 
Posts: 45
Joined: Tue Nov 25, 2014 6:54 am
Location: Heiligenhaus, Germany

Re: BT connection problem

Postby kinderkram » Sat Feb 21, 2015 11:04 am

Flow control is "off"?
Did you try to use 115k changed by AT commands?
I once had a module that refused to work properly with anything lower or higher than that for unknown reasons.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: BT connection problem

Postby Altix » Sat Feb 21, 2015 11:19 am

kinderkram wrote:Flow control is "off"?
Did you try to use 115k changed by AT commands?
I once had a module that refused to work properly with anything lower or higher than that for unknown reasons.


I haven't changed flow control in the modules, so I have to check that. But, the same module, that refuses to work with the app, works properly with the PC-BT dongle, so that I can change parameters and configurations of the AQ via GCS/PC. As flow control is set to "off" in the GCS and as this connection works perfectly, I assume, the module has to be programmed correctly already.

I changed everything to 115k just in order to check, but the results were the same.

As all modules are perfectly working on a PC connection I guess, there must be any parameter in all modules (except the working one), that prevents the connection to the Andoid app specifically, but I have not a single idea, which paramter that could be.
Regards, Michael
Altix
 
Posts: 45
Joined: Tue Nov 25, 2014 6:54 am
Location: Heiligenhaus, Germany

Re: BT connection problem

Postby kinderkram » Sat Feb 21, 2015 11:31 am

You should check the settings on the working one and then compare the others.
On most modules you can request the settings by adding a question mark like
Code: Select all
AT+UART?

will give you the board rate. Depends on the module HC04/HC05/HC06 have different command sets. You can request the version via
Code: Select all
AT+VERSION?
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: BT connection problem

Postby aBUGSworstnightmare » Sat Feb 21, 2015 11:51 am

Altix wrote:
kinderkram wrote:Flow control is "off"?
Did you try to use 115k changed by AT commands?
I once had a module that refused to work properly with anything lower or higher than that for unknown reasons.


I haven't changed flow control in the modules, so I have to check that. But, the same module, that refuses to work with the app, works properly with the PC-BT dongle, so that I can change parameters and configurations of the AQ via GCS/PC. As flow control is set to "off" in the GCS and as this connection works perfectly, I assume, the module has to be programmed correctly already.

I changed everything to 115k just in order to check, but the results were the same.

As all modules are perfectly working on a PC connection I guess, there must be any parameter in all modules (except the working one), that prevents the connection to the Andoid app specifically, but I have not a single idea, which paramter that could be.


Tested with a fresh out-of-the-box bluetooth (http://www.hobbyking.com/hobbyking/stor ... ible_.html) that was never connected to my tablet before:
- start QGC
- go to settings
- select bluetooth as TELEMETRY CONNECTION TYPE
- check that TELEMETRY LINK SPEED is set to 115200baud
- click FORGET BINDING TO BLUETOOTH DEVICES
- scan bluetooth --> a device NULL will be shown in my case --> selecting it will lead to a popup-window were I need to enter the pairing code (1234 for my module; also 0000 is quite common)
--> bluetooth telemetry is running! :)
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: BT connection problem

Postby Altix » Mon Feb 23, 2015 8:20 pm

aBUGSworstnightmare wrote:...
- click FORGET BINDING TO BLUETOOTH DEVICES
...


That was the key, thanks a lot! With the single one working properly, it was not necessary to click that option. After doing so the other ones are working now too.

So now, PIDs are the next step. With the standard setting, the MiniH is shaking like hell and the motors are getting hot within seconds :(
Regards, Michael
Altix
 
Posts: 45
Joined: Tue Nov 25, 2014 6:54 am
Location: Heiligenhaus, Germany

Re: BT connection problem

Postby aBUGSworstnightmare » Tue Feb 24, 2015 9:36 am

Altix wrote:
aBUGSworstnightmare wrote:...
- click FORGET BINDING TO BLUETOOTH DEVICES
...


That was the key, thanks a lot! With the single one working properly, it was not necessary to click that option. After doing so the other ones are working now too.

So now, PIDs are the next step. With the standard setting, the MiniH is shaking like hell and the motors are getting hot within seconds :(


REDUCE YOUR PIDS!!!!! You will burn your motors quite fast with too high PIDs. Don't know the size of your mini, but Tilman started with my set from the 300size quad (viewtopic.php?f=40&t=3857&start=40#p29465) and then worked out a suited one for his Saphira (viewtopic.php?f=40&t=4313#p30866).

Joerg

EDIT: end of OT :oops:
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: BT connection problem

Postby Altix » Tue Feb 24, 2015 10:23 am

No problem with OT Jörg ;) I was aware of the risk after reading about your experience with the 300 sized quad. Mine is even a bit smaller, its a typical 250 sized MiniH (MN1806 type motors, KISS ESCs and 6" props, 3S 1800mAh LiPo, AUW inkl. FPV equimpent about 530g) like those very popular BreakOut quads. So I landed after a few seconds (as the little devil was't flyable anyway) and checked the temperature. The base of all motors were very warm but not critically hot. But ist was clear, that I shouldn't continue. Thanks for the PIDs. I'll have look at them and hopefully understand a bit more, which parameters shall be changed and why (the AQ documentation ist quite weak in that point, unfortunately).

Coming back to the BT module, I noticed another thing, which is a bit strange to me. I can build up a connection between the MiniH and the smartphone app, change and save parameters without a problem. On both test flights I did so far, I had to land quite quickly due to the heavy shaking of the quad. In both cases, the BT module turned down before landing, the connection was broken and the little red led on the module had turned off. After disconnecting and reconnecting the LiPo, everything was fine again. The BT module is a simple HC-06 Linvor V1.8, which is specified for voltages between 3,6V and something around 6V (?). Could the voltage output of your expansion board cause the turn off of the module, or which other reasons might be responsible for that?
Regards, Michael
Altix
 
Posts: 45
Joined: Tue Nov 25, 2014 6:54 am
Location: Heiligenhaus, Germany

Next

Return to Connections

Who is online

Users browsing this forum: No registered users and 3 guests

cron