FrSky Taranis Telemetry via sPort

Radio, Telemetry, FTDI/USB, ESCs, Motors, etc.

Re: FrSky Taranis Telemetry via sPort

Postby kinderkram » Fri Jun 26, 2015 9:02 pm

Yep, that´s how I have it now.

tara2.jpg
tara2.jpg (108.63 KiB) Viewed 3771 times

You need to open the pic in a new tab to fully see it.

Still getting weird messages, connection loss etc.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: FrSky Taranis Telemetry via sPort

Postby LPR » Fri Jun 26, 2015 11:56 pm

Norbert

This youtube video shows you how mine is working. As far as I can tell it seems to work well.


Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: FrSky Taranis Telemetry via sPort

Postby Max » Sat Jun 27, 2015 12:30 am

Looks good Larry! The text messages (on bottom line and presumably on the 2nd screen) are garbled because you need to change the number of propeller blades to one (1) in the Taranis telemetry settings. Not sure that made it into the instructions anywhere... :oops:

Norbert, how old is the AQ firmware you're using? I'm wondering if it even has the extended status reporting which this relies on... If you're getting basic data like battery volts and GPS position, but not any of the custom statuses, that might be why.

So the upshot was that the firmware needed to be rebuilt? Or was it only a settings problem? Sorry, I lost track around the 2nd page of new messages... :)

Glad to see it (mostly) working though!

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: FrSky Taranis Telemetry via sPort

Postby johannes3154 » Sat Jun 27, 2015 12:45 am

Max wrote:Looks good Larry! The text messages (on bottom line and presumably on the 2nd screen) are garbled because you need to change the number of propeller blades to one (1) in the Taranis telemetry settings. Not sure that made it into the instructions anywhere... :oops:

Norbert, how old is the AQ firmware you're using? I'm wondering if it even has the extended status reporting which this relies on... If you're getting basic data like battery volts and GPS position, but not any of the custom statuses, that might be why.

So the upshot was that the firmware needed to be rebuilt? Or was it only a settings problem? Sorry, I lost track around the 2nd page of new messages... :)

Glad to see it (mostly) working though!

Cheers,
-Max

Hey max, for me, recompiling solved it and i got a stable connect.
Dont know much about the teensy architecture so far, but perhaps its like the flash of the arduino. And u have to erase that First, in order to get clean settings.
johannes3154
 
Posts: 56
Joined: Sat Jun 14, 2014 7:33 pm

Re: FrSky Taranis Telemetry via sPort

Postby kinderkram » Sat Jun 27, 2015 9:55 am

I`m using the Beta v7 - will try with the Exp v7.1

Found the settings for propellers in the basic telemetry settings (page 12 of the model).
Is there anything else to adjust? E.g. Larry´s video doesn´t show the overall voltage - do we need to adjust the source for the measurement there?
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: FrSky Taranis Telemetry via sPort

Postby Max » Sat Jun 27, 2015 11:51 am

Norbert, Any v7 should work fine. I noticed belatedly that you have DIMU also... any DIMU fw. should be new enough.

But oh yah... where's the main voltage? It's showing voltage per cell OK... that is either derived from the main voltage, or perhaps he has a cell monitor attached also? :?: Hmm, don't think it needs any special setting... though it is being reported as reading from "VFAS" sensor (there are places in the Taranis config to specify which sensor the primary voltage is coming from). Maybe that does affect it... I forget now! :oops:

BTW Larry, the "V" number next to GPS H accuracy is for vertical accuracy.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: FrSky Taranis Telemetry via sPort

Postby kinderkram » Sat Jun 27, 2015 12:27 pm

Flashed v7.1 to no avail. The Taranix establishes a connection, shows some values but after ~5secs: Connection lost.
In some rare moments it keeps the connection but doesn´t display any status changes - it stays at "Disarmed", sometimes goes to "Unknown" for unknown reasons.

The hex file from Johannes should work like it does for Larry. The only difference I can see: he´s using the standard version, mine is the Plus version. But that shouldn´t be the problem here, right?

Sorry to waste your time, Max. :oops: At least it works for 2 persons now. Good job!

Will follow Johannes´hint and try to erase the Teensy first bf I flash his hex file again...
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: FrSky Taranis Telemetry via sPort

Postby Max » Sat Jun 27, 2015 12:39 pm

Yea mine works with Plus, no problem. How close is your Tx to the Rx? I've seen occasionally that when they're too close, telemetry gets lost or garbled. Sorry... that's all I can think of at the moment!

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: FrSky Taranis Telemetry via sPort

Postby kinderkram » Sat Jun 27, 2015 1:18 pm

Started from scratch, reflashed the hex file (btw: the teensy loader performs a full erase bf flashing), set the mavbaud to 1 and plugged everything in again (rx, tx, gnd).

I now get a garbled message in the lower status bar and eventually it switches to "Armed" when engaged but then again: connection lost.

tara3.jpg
tara3.jpg (100.2 KiB) Viewed 3725 times


Also changed the distance between receiver and Taranix - same result.

tara4.jpg
tara4.jpg (110.02 KiB) Viewed 3723 times
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: FrSky Taranis Telemetry via sPort

Postby LPR » Sat Jun 27, 2015 1:28 pm

Norbert

My Taranis is NOT a Plus Taranis. I loaded Open Tx months ago but Florent noticed I did not have Lua so he loaded Open Tx with Lua added.

I have a voltage sensor, FRSKY SP-FLVS, also connected and that might make a difference.

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

PreviousNext

Return to Connections

Who is online

Users browsing this forum: No registered users and 1 guest

cron