AQ IMU Calibration GUI Beta

Ground Stations and utilities for Windows, Linux, Android, & others

AQ IMU Calibration GUI Beta

Postby xmg » Fri Sep 19, 2014 10:13 am

Hi,

this my first post here in the forum. Im working on a X8 based on the Tamara frame. Currently i'am struggling with the calculations.

Is anybody using the new AQ IMU Calibration GUI Beta? I'am trying to calibrate my AQ Board (no DIMU) and get some very high values for cal --mag (Step 3) IMU_MAG_BIAS

Code: Select all
//Step 3
//MAE: 0.855602
//AVG: 2.00121
//lowMAE = 0.112295, n[0] = 0.000095
#define DEFAULT_IMU_MAG_BIAS_X +8.189336064e+08
#define DEFAULT_IMU_MAG_BIAS_Y +7.586275875e+07
#define DEFAULT_IMU_MAG_BIAS_Z -8.409966631e+08
#define DEFAULT_IMU_MAG_BIAS1_X +1.661414892e+07
#define DEFAULT_IMU_MAG_BIAS1_Y +1.370660647e+06
#define DEFAULT_IMU_MAG_BIAS1_Z -5.470822683e+06
#define DEFAULT_IMU_MAG_BIAS2_X +1.034107250e+06
#define DEFAULT_IMU_MAG_BIAS2_Y +5.294603606e+05
#define DEFAULT_IMU_MAG_BIAS2_Z +1.076272962e+06
#define DEFAULT_IMU_MAG_BIAS3_X +2.878348833e+05
#define DEFAULT_IMU_MAG_BIAS3_Y +1.934559439e+05
#define DEFAULT_IMU_MAG_BIAS3_Z -1.323921629e+05
#define DEFAULT_IMU_MAG_SCAL_X +6.322007746e+08
#define DEFAULT_IMU_MAG_SCAL_Y +6.068168264e+08
#define DEFAULT_IMU_MAG_SCAL_Z +8.791781555e+08
#define DEFAULT_IMU_MAG_SCAL1_X -3.979066421e+06
#define DEFAULT_IMU_MAG_SCAL1_Y -2.723210860e+06
#define DEFAULT_IMU_MAG_SCAL1_Z -2.719679082e+06
#define DEFAULT_IMU_MAG_SCAL2_X +1.529832239e+05
#define DEFAULT_IMU_MAG_SCAL2_Y +8.150171856e+04
#define DEFAULT_IMU_MAG_SCAL2_Z +4.768358477e+04
#define DEFAULT_IMU_MAG_SCAL3_X +7.433170265e+03
#define DEFAULT_IMU_MAG_SCAL3_Y +7.296526924e+03
#define DEFAULT_IMU_MAG_SCAL3_Z +4.973143416e+03
#define DEFAULT_IMU_MAG_ALGN_XY -9.137992300e-01
#define DEFAULT_IMU_MAG_ALGN_XZ -6.119097059e-01
#define DEFAULT_IMU_MAG_ALGN_YX -7.343662459e-01
#define DEFAULT_IMU_MAG_ALGN_YZ +4.046725517e-02
#define DEFAULT_IMU_MAG_ALGN_ZX -4.445190934e-01
#define DEFAULT_IMU_MAG_ALGN_ZY -1.874610671e-01
#define DEFAULT_IMU_MAG_INCL -6.630000305e+01


While trying different combinations of my log files nothing really changes. I also tried the Windows an OSX version with the same result.

I tried to do the calculation using the QGC v1.3.0 with the same files and got some good results at step 3. Step 4b its running right now.

Thanx for reply,
Christoph
xmg
 
Posts: 2
Joined: Fri Sep 19, 2014 9:22 am

Re: AQ IMU Calibration GUI Beta

Postby Max » Fri Sep 19, 2014 12:01 pm

Hi Christoph, welcome to the forums.

I'd go ahead and use QGC 1.3 for AIMU calibration. 1.4 and the new standalone GUI includes newer versions of the underlying command-line calibration utilities, and I think they have some problems with MAG calibration on AIMU.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: AQ IMU Calibration GUI Beta

Postby xmg » Fri Sep 19, 2014 12:46 pm

Hi Max,

thank you for your quick reply. I did a quick check with QGC v1.4. The problem its the same there. So i will finish my calculations on v1.3

Christoph
xmg
 
Posts: 2
Joined: Fri Sep 19, 2014 9:22 am


Return to AQ Software

Who is online

Users browsing this forum: No registered users and 4 guests

cron