IMU_Rotation setting?

Ground Stations and utilities for Windows, Linux, Android, & others

IMU_Rotation setting?

Postby nikivan » Tue Sep 25, 2012 11:06 pm

Hi Everyone,

I have my AQ board mounted as per the enclosed picture. The quad is + (plus) configuration. I've tried setting IMU_Rotation setting to 45, but after restarting the board, HUD still shows incorrectly movements of the board. When tilting forward I see the horizon rolling as well. Is there anything else I need to set, or perhaps I need to use different angle (-45, or 315, or whatever)? Please help.

Thanks,
Nick

AQorientation.jpg
AQorientation.jpg (87.28 KiB) Viewed 2245 times
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm

Re: IMU_Rotation setting?

Postby GoFaster » Tue Sep 25, 2012 11:21 pm

Hi -

"IMU_ROT -45" is the correct value for that orientation. That's how mine is oriented as well.
The + or X setup only affects the motor mixing table.

Regards,
- Felix
GoFaster
 
Posts: 355
Joined: Tue Jul 03, 2012 1:20 pm
Location: Connecticut, USA

Re: IMU_Rotation setting?

Postby nikivan » Wed Sep 26, 2012 2:45 am

Thanks, Felix, but setting the value to -45 still shows the same issue. I've refreshed the settings screen to make sure the update took place. I've also noticed the HUD horizon rolls in the wrong direction (should be CCW when board is rolled CW and vice versa). I am using ground control 1.0.2 and FW 6.6 downloaded from the Wiki links.
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm

Re: IMU_Rotation setting?

Postby GoFaster » Wed Sep 26, 2012 3:17 am

Hi Nick -

Silly question but you have done the static and dynamic calibrations, run the calculations and uploaded those parameters?

- Felix
GoFaster
 
Posts: 355
Joined: Tue Jul 03, 2012 1:20 pm
Location: Connecticut, USA

Re: IMU_Rotation setting?

Postby nikivan » Wed Sep 26, 2012 3:45 am

Yes, I did.
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm

Re: IMU_Rotation setting?

Postby Max » Wed Sep 26, 2012 6:35 am

Nick, did you do the Calibso as Felix describes here: viewtopic.php?f=27&t=566&p=2448&hilit=IMU_ROT#p2448 That is, with the IMU_ROT setting already set to -45 and treating the corners as the "sides" to rotate around?

I don't have any personal experience with rotating the FC, just remembered that it was mentioned.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: IMU_Rotation setting?

Postby nikivan » Wed Sep 26, 2012 5:35 pm

Thanks, Max. No, I did the dynamic calibration with the default settings. At the time I did not even know about the existence of this IMU_ROT parameter. I thought the purpose of the calibration routine is to align each and every axis to each other. Beside, changing the parameter should force the IMU to "rotate" itself to the desired angle, no? I am thinking if this is so critical, the software should prompt you for it before running the calculations. BTW, I did my first flight yesterday in X configuration, after creating new mixing table. The quad flies even though the dynamic calibration "dance" was performed as for + type of frame.
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm

Re: IMU_Rotation setting?

Postby bn999 » Wed Sep 26, 2012 6:02 pm

The setting of IMU_ROT during data collection has no impact on the calibration process.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm

Re: IMU_Rotation setting?

Postby nikivan » Wed Sep 26, 2012 6:16 pm

Thanks, Bill. Going back to my original question, why changing IMU_ROT does not seem to do what it is supposed to do? Is this a bug?
nikivan
 
Posts: 78
Joined: Wed Jul 04, 2012 12:32 pm


Return to AQ Software

Who is online

Users browsing this forum: No registered users and 3 guests

cron