Page 1 of 2

Cannot fly in manual mode

PostPosted: Sat Dec 24, 2016 5:09 pm
by Grigoriy
Hello everyone,

Probably I do a very silly mistake, but I cannot fly even in manual mode.

1. Basically, I download a stable firmware 6.7 from here:, flash it, using QGroundControl v.1.6.1, upload parameters and set up a mixing table (which PWM is turned on), but I cannot fly even in manual mode.. I can arm/disarm motors, but when I increase throttle, nothing happens.

2. In parallel, I tried to install firmware with L1 controller (guys in the Lab bought it couple of years ago). I flash the firmware, upload parameters, provide a license key, set up a mixing table, but I can only arm/disarm, but I cannot control motors.

3. On another AQ6 I tried to install a firmware with quatos. Currently, I do not have a license key for a new board and wrote the AQ around a week ago to ask a license key for our new board (we bought it couple of years ago, when quatos did not exist yet, as I know, and license keys were not sent with boards). I think our license for quatos allows us to ask a license key. Still waiting for their response with a license key.
But I afraid that my problem might be not in license key. Again, I flashed firmware, uploaded parameters, checked mixing table, but I cannot even arm/disarm the UAV (I hope it is because of the absence of license key).

Can you give me any advise how to fly in manual mode at least in case 1.? I download a compiled firmware, provided parameters, but cannot fly.. I definitely doing something wrong.

Thank you for your time and have a nice celebration of the holidays!!

Re: Cannot fly in manual mode

PostPosted: Sat Dec 24, 2016 5:28 pm
by aBUGSworstnightmare
1) use a PID firmware, not quatos
2) load a standard mixer
3) make sure your TX is configured for correct range on ALL channels (what are you using?)
4) try to arm
5) let us know if the board arms
6) post parameters

You are constantly posting you're unable to arm! Without a valid QUATOS licence - which can't be transferred between boards since it's locked to an MCU serial number.- exactly this will happen: nothing!

So, first make sure your setup is working correctly, then try with QUATOS

Re: Cannot fly in manual mode

PostPosted: Fri Dec 30, 2016 10:45 pm
by Grigoriy
Thank you very much for your time and your answers!

Recently I received a license key for the QUATOS for the board I'm currently using! I uploaded initial parameters (which were on the AQ6 board initially), plus added a license key.

Now I'm able to arm the AQ6 board, but the motors are rotating slowly and thrust doesn't change with increasing thrust stick.
Another strange thing is that always when I turn on DX8, on AQ6 board I have 2 red LEDs: Power and Debug. I don't know why Debug is on.

I reflashed the firmware, but again see the same (motors are rotating slowly and 2 red LEDs). I use a master firmware from Aug 2015 (I downloaded it that time), which I used with M4 boards (I changed definition of boards in aq.h to Board 6 with revision 1 and added #define DIMU_VERSION 11).
Also I use QGC v1.6.1 and CrossWorks v.

2) Initially on the board I have some standard mixer, but I changed it to more convenient ports (I think I didn't save initial mixer). See attached photo:
3) I use Spektrum DX8 (I think it should be configured well, as I used it previously with AQ6 board with L1 controller before the previous AQ6 board stopped working and parameters for motors MOT are in the same range, and also I used this DX8 with M4 ladybirds).
5) board arms
6) Parameters are posted here (I changed actual license key with '00000'):

Thank you for your time!
Happy New Year!

Re: Cannot fly in manual mode

PostPosted: Fri Dec 30, 2016 10:56 pm
by aBUGSworstnightmare

no data for your prop+engine thrust curve, no scale value (100 for Standard PWM ESCs) --> no flying!
How should Quatos know with these parameters all zero?

You should do a Tare at least (calibrate DIMU) and don't forget to calibrate as your MAG.
Inclination/declination also not set...
Sorry, Do you follow the wiki or do you just ask in the forum instead of doing the basic setup first?

Re: Cannot fly in manual mode

PostPosted: Sun Jan 08, 2017 12:06 am
by Grigoriy
Thank you for your comments!
I followed all steps, but I still cannot fly in a manual mode (the UAV flips upside down once it takes off).

I did a Tare calibration: ... libration/

I could not measure prop+engine thrust curve, as I don't have a setup for it. ... rpolation/
Instead, I used parameters for
MOT_VALUE2T_A1 0.300000011921
MOT_VALUE2T_A2 0.000399999989895
from viewtopic.php?p=27289
as they have a similar motor and props: XMotor 2208 with 0845 HQ props, while I have TMotor MT2208.

I could not do ESC calibration: ... ibrations/
I connected an ESC32 with FTDI connector, but it cannot measure current (see a screenshoot):
Imagepost image online
Feed Forward calibration fails the same way: it cannot measure values (zeros for values of current, rpm, as I remember).
Does anybody saw such a problem previously, when you cannot calibrate ESC?

Current parameters of my ESC32 attached:
Imagephoto uploading
These ESC32 were previously calibrated to with an L1 controller. Previously guys in my Lab bought an L1 controller, but later AQ6 board burned and we decided to switch to Quatos (the company where they bought a board with L1 controller, doesn't exist anymore and we don't have a way to have a new serial number).

Parameters for my AQ6 board look as follows (I put 00000 instead of real license key for Quatos):

So, I did a Tare calibration; set magnetic declination and inclination; but I didn't do a compass calibration (it's too many electronic devices and metal around, in the Lab - I afraid that after compass calibration it will become only worse).
I hope compass calibration is not very crucial for flying indoors in a manual mode.

Unfortunately, the UAV is flipping upside down: as soon, as I take off, the UAV is abruptly falling upside down around 30 cm to a side from a taking off position. It doesn't keep a vertical position: as it stops touching a foam, it just flips.

Do you have an idea what I could check to fix such a behavior? I just want to take off vertically, without falling right away.
Thank you for your time and have a good day!

Re: Cannot fly in manual mode

PostPosted: Sun Jan 08, 2017 1:57 am
by LPR

My guess is that you have the motors not correctly connected or the AQ board is not in the proper orintation.


Re: Cannot fly in manual mode

PostPosted: Sun Jan 08, 2017 9:55 am
by aBUGSworstnightmare
BEFORE trying to lift off one should check each individual motor if it's in the right position and rotation.
No need to disconnect anything, simply switch them to the interface you're NOT using and then switch one-after-the other to the right one, arm and check if everything is right.

That means:
- in case of PWM: switch all to CAN, then switch one to PWM, arm and check position/rotation
- in case of CAN: switch all to PWM, then switch one to CAN, arm and position/rotation

Without proper ESC32 calibration flying will not be possible!

MOT_VALUE_SCAL from your example is wrong! This would result in 950RPM only!!! Forget QUATOS if can have no parameters for your setup on hands or until you're able to measure thrust (side not: you only need a digital kitchen scale and a motor test stand; My kitchen scale price was 9,95EUR, my test stand is this one ... dNr=PA008; the results are quite good and all my Quatos copters are flying well).

Are you using Linux! Maybe you should try with Windows or OSx. Which Version of ESC32 do you have (V2 or V3)? In case of V3 I recommend to use AQ ECU ( ... n-utility/).

Re: Cannot fly in manual mode

PostPosted: Wed Jan 11, 2017 6:45 pm
by Grigoriy
Thank you very much for your detailed comments!

We managed to fly the UAV in the manual mode quite decently: we noticed that if we make DIMU calibration, it calibrates well, then we click "Calib. Save", then "refresh" -> "Transmit" -> "Write Flash". Then we can fly decently in the Manual mode.
But if we restart the UAV the calibration should be done again (please take a look at the following picture before and after calibration). After the restart we should do "DIMU calibration" again.

Uncalibrated view and parameters:
Imagefree image uploading

Calibrated view and parameters:
Imagefree image hosting

One thing we haven't done is Compas calibration. In the wiki it is written that we should avoid having any metal around, but in our Lab we have a huge amount of metal, wires, devices, etc. I afraid that the MAG calibration will make values only worse (comparing to default values).

Is it mandatory to do Compass calibration to be able to save Tare calibration values?
If now we could save Tare calibration results, maybe it will be good enough for flying in the Lab. I guess the problem is in the initial calibration during the UAV's booting. Maybe we have to turn off somehow UAV's automatic calibration during booting. But it looks that it upload the same parameters from the memory: it always uploads offset in 20 degrees into pitch direction. As a result, the UAV falls into the North direction, if we restart the UAV before flying.

The UAV's parameters are here:

Thank you very much for your time!

Re: Cannot fly in manual mode

PostPosted: Wed Jan 11, 2017 8:29 pm
by Max
Grigoriy wrote:then we click "Calib. Save"

What does AQ respond with? Confirmation of success?

Grigoriy wrote:then "refresh" -> "Transmit" -> "Write Flash"

This is a "null op." There should be no changed params to transmit or save after a refresh.

To me it sounds like the calibration data isn't being saved to EEPROM for some reason.

Grigoriy wrote:Is it mandatory to do Compass calibration to be able to save Tare calibration values?


Grigoriy wrote:I afraid that the MAG calibration will make values only worse (comparing to default values).

Doesn't hurt to try (after you solved the eeprom saving issue). I do calibrations on my workbench, with a lot of metal around, and it's fine. A good mag calibration will make the initial attitude estimate more accurate. A bad one will have the opposite effect (will show a bit off-level even when tare is perfect).


Re: Cannot fly in manual mode

PostPosted: Wed Jan 18, 2017 6:07 pm
by Grigoriy
Thank you for your feedback!

I just tried to do calibration again and I have the same result: it doesn't save calibrated values.

I use QGC 1.7 under Ubuntu.
1. I do TARE calibration as "DIMU Tare" using the left bottom button.
2. I click "Calib. Save" to save calibrated results.
3. I see the following message "DIMU: wrote calibration parameters to EEPROM" (open the full image and see on the right top).
4. I restart the AQ using a red button "Restart".
5. The calibration seems to be not done (it has huge offsets again).

Am I right, that I have a problem with saving on this specific board, but in general it should save the calibrated parameters using these steps?
May this problem appear because of a wrong firmware? I use a firmware, which I downloaded under "master" branch on AQ's Github around Aug 2015 (I want to use that one because I did some changes in Navigation part of the firmware).