Compiler Error'mavlink_system_t' has no member named 'state'

News, Setup, Compiling, Flashing, Development

Compiler Error'mavlink_system_t' has no member named 'state'

Postby Florian75 » Tue Mar 15, 2016 1:14 pm

Hello,

i cant compile the AQ firmware. I get the Message "'mavlink_system_t' has no member named 'state'"

i would like to create an actual AQ Crossworks Project:

Step1:
https://code.google.com/archive/p/autoq ... ult/source
and download the repo (Download the code for this repo. (13.43MB) )

Step2:
https://github.com/AutoQuad/mavlink_headers
and Download ZIP

Step3:
Download the STM32F4xx_DSP_StdPeriph_Lib_V1.3.0 from (ftp://ftp.autoquad.org/3/334693_22529/3rdParty/)
btw the Link on the page "http://autoquad.org/wiki/wiki/building-developing/firmware/development/" does not work

Without "#define USE_MAVLINK" it works. The compiler builds the *.hex file. But with "USE_MAVLINK" the compiler is missing some members in the "mavlink_system_t".

/**
* This structure is required to make the mavlink_send_xxx convenience functions
* work, as it tells the library what the current system and component ID are.
*/
MAVPACKED(
typedef struct __mavlink_system {
uint8_t sysid; ///< Used by the MAVLink message_xx_send() convenience function
uint8_t compid; ///< Used by the MAVLink message_xx_send() convenience function
}) mavlink_system_t;

What is the problem? Is there a change in the precompiled MAVLINK Header file?

regards
Florian
Florian75
 
Posts: 48
Joined: Wed Oct 09, 2013 7:35 am

Re: Compiler Error'mavlink_system_t' has no member named 'st

Postby Max » Tue Mar 15, 2016 5:17 pm

Not sure which version you're building from that repo... all the branches/versions are in one zip file?

Use the new repos: http://github.com/bn999/autoquad or http://github.com/mpaperno/aq_flight_control

The latter has instructions for using with latest version of CW, and all libraries are included.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Compiler Error'mavlink_system_t' has no member named 'st

Postby Florian75 » Tue Mar 15, 2016 9:17 pm

Hello Max,

yes there are all branches and versions in the zip file. I tried the branch 7.0

My CrossWorks version is the 2.3.3.

Is there any difference between Bills an yours repo?

regards
Florian
Florian75
 
Posts: 48
Joined: Wed Oct 09, 2013 7:35 am

Re: Compiler Error'mavlink_system_t' has no member named 'st

Postby Max » Tue Mar 15, 2016 9:51 pm

Hi Florian,

Yea 7.0 won't work with the latest Mavlink due to some changes in their structures around beginning of last year. You'd have to dig up an older Mavlink version to build AQ 7.0 or lower. First AQ fw version to support the new structures is 7.1 r446 b1848.

Yes there are quite a few differences... exactly what they are depends on which branch of my repo you choose. `master` branch is stable but dated. Most changes since Bill's version are summarized here: https://github.com/mpaperno/aq_flight_c ... CHANGES.md and the very latest which people have been testing lately is here: https://github.com/mpaperno/aq_flight_c ... CHANGES.md

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Compiler Error'mavlink_system_t' has no member named 'st

Postby Florian75 » Wed Mar 16, 2016 9:02 am

Hi Max,

thanks for your answer.

I tested the 7.0 with an older MAVLINK Version and it works! I will check the other repos to find the best version for me.
Thanks for your help.

regards
Florian
Florian75
 
Posts: 48
Joined: Wed Oct 09, 2013 7:35 am


Return to AQ Firmware

Who is online

Users browsing this forum: No registered users and 6 guests