Another problem compiling with CrossWorks 3.3

News, Setup, Compiling, Flashing, Development

Re: Another problem compiling with CrossWorks 3.3

Postby HeliHenkie » Wed Dec 10, 2014 6:58 am

Hi Max, Steve,

Thanks for your reply.

@Steve: If everything goes according to plan I will receive a Quatos license for my brand new AQ board. So the availability of Quatos should be no problem. If you or Menno need a beta tester to speed up public release of the adapted firmware I'm your man! My quadcopter is an exact copy of the reference quad 400 Angel presented in the AQ media showcase.

Best regards,

Jan Willem
The Netherlands
HeliHenkie
 
Posts: 93
Joined: Wed Oct 24, 2012 5:33 pm

Re: Another problem compiling with CrossWorks 3.3

Postby HeliHenkie » Sun Dec 14, 2014 9:31 am

Hi all,

With CrossWorks 3.3 compiling works but linking fails.
See attached image for program output.
Did anyone encounter the same problem and have a solution?

Best regards,

Jan Willem
The Netherlands

linking_error.JPG
HeliHenkie
 
Posts: 93
Joined: Wed Oct 24, 2012 5:33 pm

Re: Another problem compiling with CrossWorks 3.3

Postby DUKE40 » Sun Dec 14, 2014 10:46 am

Hi Jan,

as far as I know, only team members can compile a Quatos based firmware, as the required libraries are only available to them and will never be released outside the AutoQuad Team.
This might be the reason for your compiling / linking failing.
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Another problem compiling with CrossWorks 3.3

Postby Max » Sun Dec 14, 2014 11:47 am

Jan, try this: viewtopic.php?f=31&t=3825&start=10#p26961

The problem is very likely the versions of those 2 files mentioned. Replace them from the STM32...Lib_V1.3.0 distribution as mentioned in that post (don't use 1.4.0). If you don't have 1.3.0, I put a copy up on our FTP site.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Another problem compiling with CrossWorks 3.3

Postby HeliHenkie » Sun Dec 14, 2014 6:57 pm

@Max: Almost there compiling my own firmware with the "Makefile method" on my Windows 7 PC.
Only one problem left while linking.
I seem to be missing the following file: c:/cw/lib/libc_targetio_impl_v7em_fpv4_sp_d16_hard_t_le_eabi.a
This file was not installed with CrossWorks 3.3 .

Does this problem seem familiar to you?
Could you post the missing file?

Best regards,

Jan Willem
The Netherlands
HeliHenkie
 
Posts: 93
Joined: Wed Oct 24, 2012 5:33 pm

Re: Another problem compiling with CrossWorks 3.3

Postby aBUGSworstnightmare » Sun Dec 14, 2014 7:59 pm

HeliHenkie wrote:@Max: Almost there compiling my own firmware with the "Makefile method" on my Windows 7 PC.
Only one problem left while linking.
I seem to be missing the following file: c:/cw/lib/libc_targetio_impl_v7em_fpv4_sp_d16_hard_t_le_eabi.a
This file was not installed with CrossWorks 3.3 .

Does this problem seem familiar to you?
Could you post the missing file?

Best regards,

Jan Willem
The Netherlands
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Another problem compiling with CrossWorks 3.3

Postby aBUGSworstnightmare » Sun Dec 14, 2014 8:05 pm

HeliHenkie wrote:@Max: Almost there compiling my own firmware with the "Makefile method" on my Windows 7 PC.
Only one problem left while linking.
I seem to be missing the following file: c:/cw/lib/libc_targetio_impl_v7em_fpv4_sp_d16_hard_t_le_eabi.a
This file was not installed with CrossWorks 3.3 .

Does this problem seem familiar to you?
Could you post the missing file?

Best regards,

Jan Willem
The Netherlands


Hi Jan,
Can't help you out for tue moment since I'm really really far afk :oops:
Just one thing to notice: CW 3.3 produces smaller code (Flash). Since official releases are based in V2.3 you should be carefull when testing! I havent seen any issues so far with my V3.3 custom firmwares, although I tend to compile with v2.3 for field use.
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm

Re: Another problem compiling with CrossWorks 3.3

Postby tevada2010 » Mon Jan 11, 2016 3:30 am

I am too. Use CrossWorks 3.3 problem can't found stm32f4xx.h: No such file or directory. Help.
Image
tevada2010
 
Posts: 6
Joined: Tue Jul 03, 2012 10:48 am

Previous

Return to AQ Firmware

Who is online

Users browsing this forum: No registered users and 8 guests

cron