Can Autoquad compile with Coocox ide?

Info and discussion about the original AQ v6 flight controller

Can Autoquad compile with Coocox ide?

Postby tevada2010 » Sat Feb 06, 2016 5:31 am

I want to know.
Can Autoquad fireware compile with Coocox ide?
tevada2010
 
Posts: 6
Joined: Tue Jul 03, 2012 10:48 am

Re: Can Autoquad compile with Coocox ide?

Postby Max » Sat Feb 06, 2016 8:00 am

An IDE does not compile code. You need a build "toolchain" (ARM compiler, includes, libraries, etc). The only toolchain currently supported is included with CrossWorks 2.3 from Rowley (they have a version in their archives). This doesn't mean you have to use their editor (IDE), but you do need their compiler/etc.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Can Autoquad compile with Coocox ide?

Postby tevada2010 » Sat Feb 06, 2016 3:07 pm

I use crosswork 2.3 it error.
Image
tevada2010
 
Posts: 6
Joined: Tue Jul 03, 2012 10:48 am

Re: Can Autoquad compile with Coocox ide?

Postby bn999 » Sat Feb 06, 2016 3:34 pm

If I remember correctly, that is a bug in STM's driver libraries. Try to remove or exclude that file from the build.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm


Return to AutoQuad 6 Flight Controller

Who is online

Users browsing this forum: No registered users and 7 guests