Can,t get RC communication to work.

Info and discussion about the original AQ v6 flight controller

Can,t get RC communication to work.

Postby gredeby » Thu Jan 01, 2015 4:53 pm

Hi ,
I flashed my AQ6 board with aqv6.9.r346.b1638-rev1.hex and I can,t get RC to work.
I use the latest ground control 1.6. The bars don,t move at all. The signal quality is 0%. Is the reciever bad?
My reciever is a spektrum sattelite it worked before I flashed the board.I picked RC1 11 bitRx.
I,m appreciates any input that can solve my issue.
gredeby
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Re: Can,t get RC communication to work.

Postby chschmid » Thu Jan 01, 2015 5:10 pm

What receiver did you use to bind the sat to your Tx?
Rx < 8000 would be 10 bit
Rx >= 8000 would be 11 bit

Cheers
Christof
chschmid
 
Posts: 1800
Joined: Wed Jul 11, 2012 7:41 pm
Location: Herrliberg, Switzerland

Re: Can,t get RC communication to work.

Postby gredeby » Thu Jan 01, 2015 6:32 pm

I used 8000 Rx, it was binded to the Tx before I flashed the new fw.
Something happened .
gredeby
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Re: Can,t get RC communication to work.

Postby kinderkram » Thu Jan 01, 2015 6:49 pm

Hi gredeby,
please flash the new v7 beta for your AQ6 and try again.
http://autoquad.org/software-downloads/ ... ad-wizard/
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Can,t get RC communication to work.

Postby gredeby » Thu Jan 01, 2015 7:29 pm

I, ll test that tomorrow, and come back then. Thanks
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Re: Can,t get RC communication to work.

Postby gredeby » Thu Jan 01, 2015 9:12 pm

Kinderkram, I have flashed it with the new v7 beta, but no luck.
In radio control setting "signal quality" is 0%. It must mean something, bad Rx or what?

But my m4 is a sucsess I must say, Position & alt hold works great so does the RTH. :D
It,s so stable & smoth. I changed the 3D printed frame to a lady bird, the 3D printed frame i had on the crappy
video was a bit heavy my time in air was only 1,5min. With the lady bird it is 6min. I ordered i more m4
from Jussi.
gredeby
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Re: Can,t get RC communication to work.

Postby Max » Thu Jan 01, 2015 10:32 pm

Hi gredeby, are your radio settings correct? Things have changed a bit in v7, so you might want to double check that. What does it say in the Onboard Parameters list for RADIO_TYPE and RADIO_SETUP?

Also check the AQ startup messages -- with fw v7 it should give you an indication that it initialized the RC port.

Which fw did you have installed before, and if you go back to that, does the radio start working again?

Glad you're enjoying the M4!

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: Can,t get RC communication to work.

Postby gredeby » Fri Jan 02, 2015 10:39 am

Hi Max I have RADIO_TYPE=-1 RADIO_SETUP=7
I Flashed it back to the previus FW, but it didn,t work.
So I,m back to FW v7

[quote][/Also check the AQ startup messages -- with fw v7 it should give you an indication that it initialized the RC port]
I don,t no how to do that.
gredeby
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Re: Can,t get RC communication to work.

Postby kinderkram » Fri Jan 02, 2015 11:07 am

Your radio setup is wrong. For ext. 11bit Spektrum it should be 1, not 7 (which is the internal Deltang for the M4v1).

You can check startup messages in the "Communication Console" widget. To see full messages again, press "restart" in the "Onboard Parameters" tab.
kinderkram
 
Posts: 2911
Joined: Fri Jun 22, 2012 7:47 am

Re: Can,t get RC communication to work.

Postby gredeby » Fri Jan 02, 2015 1:33 pm

Thanks a lot.
I, m grateful for the help. You are so kind to noobs here . I read somewhere on the
wiki it should be -1 & 7. But it works now with the figures you gave me.
gredeby
gredeby
 
Posts: 27
Joined: Thu Dec 20, 2012 7:28 pm

Next

Return to AutoQuad 6 Flight Controller

Who is online

Users browsing this forum: No registered users and 3 guests

cron