[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 488: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4789: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4791: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4792: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4793: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3916)
AutoQuad Forum • View topic - Calibration: MAG values outside of the range

Calibration: MAG values outside of the range

Info and discussion about the original AQ v6 flight controller

Calibration: MAG values outside of the range

Postby Mlozano » Sat Mar 22, 2014 5:26 pm

In order to improve the results that I exposed in the post:

viewtopic.php?f=35&t=2997

, I have done three statics calibrations in the same place where I did the calipso dance (travelling 10 min with a small isothermic bag). The temperature scale is -12 to 55 ºC.

The MAE Value of these file are better than before (MAE 0 = 0.000124, MAE 1 = 0.000123, MAE 2 = 0.000135) and the IMU_RATE graphs are similar each other.

The HUD is better leveled when the AQ is on the frame than when isn't onboard

no_onboard:

HUD_leveled_noBoard.png
HUD no onboard

DSCN8673_1.JPG
on the table

DSCN8672_1.JPG
on the table


on_board:

HUD_leveled_onboard.png
HUD_onboard

DSCN8671_1.JPG
on the frame

DSCN8670_1.JPG
on the frame


Also I was expecting to improve the MAG and ACC magnitude in any orientation, but not. Now ACC magnitude is 9.6 in any orientation (its ok but not great), but MAG magnitude it depends of the orientation (2.4; 2.6; 2.4;2.2), far away of the range 1.95 to 2.05.

Maybe the ESC4in1 that I have below the AQ board is the responsable of the MAG Value desviation.



The summary of the calculation can be downloaded from:



I would appreciate any help. I'm exhausted with the calibration process...

Thanks...
Last edited by Mlozano on Mon Mar 24, 2014 1:49 pm, edited 5 times in total.
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby Mlozano » Sun Mar 23, 2014 11:40 am

STATIC RATE
Attachments
STATIC_RATE_1.png
SESSION 1
STATIC_RATE_2.png
SESSION 2
STATIC_RATE_3.png
SESSION 3
Last edited by Mlozano on Sun Mar 23, 2014 12:30 pm, edited 1 time in total.
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby Mlozano » Sun Mar 23, 2014 12:21 pm

STATIC ACC SESSIONS
Attachments
STATIC_ACC_1.png
SESSION 1
STATIC_ACC_2.png
SESSION 2
STATIC_ACC_3.png
SESSION 3
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby Mlozano » Sun Mar 23, 2014 12:23 pm

STATIC MAG SESSIONS
Attachments
STATIC_TEMP0_1.png
TEMPERATURE CURVE SESSION 1
STATIC_TEMP0_2.png
TEMPERATURE CURVE SESSION 2
STATIC_TEMP0_3.png
TEMPERATURE CURVE SESSION 3
STATIC_MAG_1.png
SESSION 1
STATIC_MAG_2.png
SESSION 2
STATIC_MAG_3.png
SESSION 3
Last edited by Mlozano on Sun Mar 23, 2014 12:44 pm, edited 1 time in total.
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby Mlozano » Sun Mar 23, 2014 12:26 pm

DYNAMIC SESSION
Attachments
DYN_ACC.png
DYN_RATE.png
DYN_MAG.png
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby Mlozano » Sun Mar 23, 2014 12:29 pm

TEMPERATURE COMPENSATION
Attachments
TEMP_COMP_ACC.png
TEMP_COMP_MAG.png
TEMP_COMP_RATE.png
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby LordPikaChu » Mon Mar 24, 2014 6:38 pm

Have you tried flying your copter with this calibration data? I've had similar issues where AQ couldn't find the correct level and was drifting badly and I blame MAG noise coming from power distribution and other components for that. What I can tell you is that having ESCs directly below AQ is definitely not a good idea, at least until the DIMU (which supposedly lets AQ not use MAG data form flying) comes out.
LordPikaChu
 
Posts: 93
Joined: Fri Aug 09, 2013 12:42 pm
Location: Poland, Lodz

Re: Calibration: MAG values outside of the range

Postby Mlozano » Mon Mar 24, 2014 10:20 pm

No, I didn't try to fly because I'm a newcomer and I don't know the consequences of the MAG desviation. To take a desicion, I need to confirm that the statics and dynamic files are ok. If the files are not ok I will try to improve them, if not maybe I will try to fly.

What's the effect of mag desviation? Is it a great problem in order to fly?
Can I control the problem with the navigation PIDs? Can I fly it with some security?

In my opinion, the problem could come from an interference because the results with differents files are similar.

Do you know a way to confirm that possibility?

In that sense, last night I was trying to compare differents MAG logs with differents positions and situations: with and without electronics components and with and without frame. Before replacing any component, If I can confirm the interferences, I will try an EMI shield.

Please, see this link:
http://diydrones.com/profiles/blog/show ... 4#comments

Unfortunately, now I have a more serious problem because I can't comunicate with the board. If I can resolve the problem I will try to finish the test. I would appreciate if you could help me to find out a solution. viewtopic.php?f=27&t=3033

Thank you for your answer,

Mlozano
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Re: Calibration: MAG values outside of the range

Postby chschmid » Mon Mar 24, 2014 10:39 pm

chschmid
 
Posts: 1800
Joined: Wed Jul 11, 2012 7:41 pm
Location: Herrliberg, Switzerland

Re: Calibration: MAG values outside of the range

Postby Mlozano » Mon Mar 24, 2014 11:52 pm

I'm trying to connect with 115200 baud rate, but nothing. Always I connected with 115200 baud. I have checked the continuity with a tester and the solders are ok, but I will solder the pins again. Sorry for my english but I don't know what you say with "Maybe you can try Putty to see if you can get a connection".

Thanks
Mlozano
Mlozano
 
Posts: 45
Joined: Wed Mar 27, 2013 10:51 pm

Next

Return to AutoQuad 6 Flight Controller

Who is online

Users browsing this forum: No registered users and 5 guests

cron