Motor not spinning with propeller on

Info and Discussion about the ESC32 hardware and software

Motor not spinning with propeller on

Postby naikin » Mon Apr 11, 2016 5:19 pm

I am using ESC32 v2, UT-2217 motors (http://www.unmannedtechshop.co.uk/brush ... 17q-880kv/) and 12x4.5 propeller. When I connect to the ESC via FTDI and make it start it spins fine at all possible speeds. When I put propeller on, and do the same, I get scraping noises from the motor and very small oscillations (no spinning). In a few seconds the ESC disarms on its own (I guess because it determines that sth is wrong). If I try running the calibration described in the wiki, result is the same. It has been suggested to me that this is most probably a sync issue and I should try giving the motor a small push so that it starts. Indeed, that was the case so I tried adjusting the ADVANCE value in the control table so that motor can start on its own. I tried every possible integer, but result was always the same.

EDIT:

I tried propeller 11x4.7 as well. The initial behavior when I start the motor is the same, but the motor eventually starts spinning. I successfully ran the current limiter calibration and the feed forward calibration. When I put the 12x4.5 propeller after that, motor again did not start.

Any suggestions how this issue can be fixed? I want to use the 12x4.5 propeller. Here is the current control table for the ESC (after running the calibration for 11x4.7):

STARTUP_MODE = 0
BAUD_RATE = 230400 baud
PTERM = 0.250
ITERM = 0.00060
FF1TERM = +1.05532e-07
FF2TERM = +1.01535e-03
CL1TERM = +9.10266e-01
CL2TERM = +8.19136e-04
CL3TERM = +1.12699e-01
CL4TERM = +8.19820e-05
CL5TERM = +5.62973e-01
SHUNT_RESISTANCE = 0.500 mohms
MIN_PERIOD = 50 us
MAX_PERIOD = 12000 us
BLANKING_MICROS = 30 us
ADVANCE = 15.00 Degs
START_VOLTAGE = 1.10 Volts
GOOD_DETECTS_START = 75
BAD_DETECTS_DISARM = 48
MAX_CURRENT = 0.0 Amps
SWITCH_FREQ = 20.0 KHz
MOTOR_POLES = 14
PWM_MIN_PERIOD = 2200 us
PWM_MAX_PERIOD = 25000 us
PWM_MIN_VALUE = 750 us
PWM_LO_VALUE = 1000 us
PWM_HI_VALUE = 1950 us
PWM_MAX_VALUE = 2250 us
PWM_MIN_START = 1100 us
PWM_RPM_SCALE = 6500 RPM
FET_BRAKING = 0
PNFAC = 10.00
INFAC = 0.15
THR1TERM = +0.00000e+00
THR2TERM = +1.00000e+00
START_ALIGN_TIME = 600 ms
START_ALIGN_VOLTAGE = 0.90 Volts
START_STEPS_NUM = 0
START_STEPS_PERIOD = 16000 us
START_STEPS_ACCEL = 0 us
PWM_LOWPASS = 0.00
RPM_MEAS_LP = 0.500
SERVO_DUTY = 16.0 %
SERVO_P = 0.050
SERVO_D = 0.000
SERVO_MAX_RATE = 1000.0 deg/s
SERVO_SCALE = 360.0 deg
ESC_ID = 0
DIRECTION = 1
naikin
 
Posts: 2
Joined: Mon Apr 11, 2016 5:03 pm

Re: Motor not spinning with propeller on

Postby bn999 » Mon Apr 11, 2016 8:24 pm

First set everything back to factory defaults, then try increasing your START_VOLTAGE.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm

Re: Motor not spinning with propeller on

Postby naikin » Mon Apr 11, 2016 10:59 pm

Thanks so much, that worked. What reasoning should I use to decide what value to leave it to?
naikin
 
Posts: 2
Joined: Mon Apr 11, 2016 5:03 pm

Re: Motor not spinning with propeller on

Postby bn999 » Tue Apr 12, 2016 1:09 am

I'd set it to the lowest value that provides consistent starting.
bn999
 
Posts: 1559
Joined: Thu Jun 21, 2012 11:40 pm

Re: Motor not spinning with propeller on

Postby aBUGSworstnightmare » Tue Apr 12, 2016 6:25 am

Which voltage do you use - 3S or 4S?

Your motor looks quite similar to the 3DR x8+ motor. Find my data for this motor below; they should give you an idea which parameters you (may have) to change.

As Bill pointed out already: increase start voltage and start align voltage until your motor starts properly. Also try with higher settings for ADVANCE.

Here are the parameters that I've used for this motor on 4S with a Graupner e-Prop 11x5 (ESC32V2 with latest firmware); parameters are for closed loop mode!
ADVANCE 12
CL1TERM -0.097567
CL2TERM 0.00131579
CL3TERM -0.0190986
CL4TERM -2.02028e-05
CL5TERM 1.56474
FF1TERM 6.33612e-08
FF2TERM 0.00123812
MAX_CURRENT 13
MOTOR_POLES 14
PWM_RPM_SCALE 8100
STARTUP_MODE 1
START_ALIGN_TIME 600
START_ALIGN_VOLTAGE 1.05
START_STEPS_PERIOD 20000
START_VOLTAGE 1.25
SWITCH_FREQ 20

ESC32_v2.1.0.6180_cal_CL_13A_3drx8p_4s_eprop11x5.jpg
Virtual Current Limiter Calibration

ESC32_v2.1.0.6180_cal_R2V_13A_3drx8p_4s_eprop11x5.jpg
R2V calibration
aBUGSworstnightmare
 
Posts: 1460
Joined: Fri Jun 22, 2012 5:24 pm


Return to ESC32

Who is online

Users browsing this forum: No registered users and 5 guests