Page 1 of 1

Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Tue Aug 25, 2015 5:06 am
by Max

Hello World,

I am pleased to officially announce new companion software for the AutoQuad ESC32. The ESC32 Configuration Utility (ECU) is a comprehensive tool for all ESC32 configuration, calibration, testing, and diagnostics.

Major Features
  • Full, intuitive graphical user interface for all aspects of ESC management, with inline help tips throughout.
  • Connect multiple ESCs at the same time (only limited by available USB/serial ports).
  • Supports all ESC32 hardware versions, including v2 and the new v3.
  • Full ESC parameter management with change preview and import/export options.
  • An advanced ESC Calibration process with a rich interface, which works on all operating systems.
  • View and/or log real-time ESC telemetry data, and chart any available values.
  • Easily arm and run the ESC/motor with various settings, for testing and telemetry data collection.
  • Built-in custom serial console for “advanced” CLI use or diagnostics.
  • Firmware update “wizard” guides and automates upgrades of supported ESC hardware.

ecu_config_675px.png (143.93 KiB) Viewed 13142 times

ecu_calibration_CL_finished_675px.png (199.32 KiB) Viewed 13142 times

More screenshots are available here.

ECU is available for Windows and Mac OS X operating systems (Linux coming soon).

AQ ECU is released as commercial software and requires a license. Each ESC32 v3 will include a special license for the ECU! This license will allow use with v3 ESCs only. For use with ESC32 v2, a license for the ECU must be purchased separately.

More details on licensing, purchase, and downloads are available on the product web page.

We have also started a set of documentation for ECU at the AQ wiki, with more soon to come.

ECU is written by me and published by my company, World Design Group, in cooperation with Viacopter and the AutoQuad project.

For ESC32 v2 you may of course continue to use the existing ESC32 Settings tab in AQ QGroundControl if you prefer. However, do not use AQ QGC with ESC32 v3! The configuration parameters are not compatible and you will end up with mixed-up settings. AQ ECU is the only graphical user interface compatible with ESC32 v3.

I hope you enjoy the software, and please let me know if you have any questions! Stay tuned for more news about ESC32 v3. ;)


Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Sat Aug 29, 2015 11:10 am
by Astudillo
Hi Max,

Looks like a really awesome tool! But im trying to run in on my mac, and i get a error that i'm missing a library.
Library not loaded: /Users/max/Qt/5.4/clang_64/lib/QtSvg.framework/Versions/5/QtSvg

Installed QT 5.4 but still got the same message, so i made a user folder named "max" in my user folder. And copied the QT folder in it, and it works now.



Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Sat Aug 29, 2015 11:48 am
by kinderkram
Looks like there´s a wrong path in the setup, locally set to Max`user folder.
Thx for posting the workaround.

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Sun Aug 30, 2015 4:46 pm
by Astudillo
Hey Guy's,

Received my V3's in the mail and have put them on the bench today.


The ECU registration process is quite strait forward so no problems there.
Started with a RPM/Voltage calibration. Witch gave me a nice csv file whit a lot of rpm,volt and amp data, aswel as a nice graph of the data.
Schermafbeelding 2015-08-30 om 16.51.06.png

I wanted to make thrust calculations as well as i'm using quatos. So i went over to the telemetry, started the telemetry armed and clicked run. Everything was running smooth so i increased my rpm which eventually gave some problems.

I started with 6000rpm, but it only ran 3000rpm(showing in the telemetry) an giving this error message:
ESC unexpectedly entered disarmed state.
But the motor was still spinning and i wasn't able to disarm, so i killed the power and tried again.
I started with 6000rpm again but ran on 3200rpm, i change it to 4000, it runs at 6000rpm. I changed it to 4050, it stalls and says armed(voice). bus does not start or disarm, and ging the same "ESC unexpectedly entered disarmed state." error message. Had to reboot the v3 to get it working again, closed and opened ECU and then worked from 6000rpm.
I'm not sure if this is a problem of the ECU or the V3's. I have v2's aswel but no license for them.
I also noticed when you want to start a log in the telemetry window the default filename "ESC32_ESC_1_on_/dev/cu.usbmodem1411_telemetry" gives write errors probably from the "/" in the name. If you change it works fine. What i also found was if you start telemetry and start a log, and stop the log before you stop the telemetry it crashes the application. If you stop telemetry first and then the log it works fine!

Besides the problems i ran in to i think its a awesome piece of software Max made which can make life a lot easier!



p.s. im running OSX 10.10.5

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Sun Aug 30, 2015 9:58 pm
by kinderkram
Your problems are partitially related to the MacOS version - but the thrust part sounds strange.
Did you try to start with lower values than 6000rpm? Just to see if it acts the same...

Do you have access to a Windoze PC to compare with the Win version?

One important thing is the quality of the USB cable - but I guess you fully trust Apple. ;)

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Sun Aug 30, 2015 11:06 pm
by Astudillo
@kinderkram the usb cable is actually from my samsung tablet :P

Ill borrow a windows machine at work tomorrow and check it out. I have to say that i had some trouble with my Usb(3) ports on macbook with the M4. That if i reboot the M4 from the QGC the whole systems freezes. On my old mac that doesn't occur. So i could check that as well.

I did try different rpm's, it also happend at 300rpm 900rpm,3000rpm and 9300rpm. The v3 was non responsive at arming or disarming,but did still show a active telemetry. But i had to reboot the V3 and than it would spin up, but not at the displayed rpm(despite pushing the enter key). Sometimes i just had to go up or down 50rpm to get it at the right rpm, but sometimes it stalled and one time it didn't stop spinning. But nothing consistently.

I will try it on another machine, and see if i can replicate the problem. I also wil look for some other micro usb cables to be sure. 8-)



Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Mon Aug 31, 2015 4:38 am
by Max
Hi Ray,

Thanks for the reports, and sorry about the troubles. Looks like a packaging mistake on that latest Mac version, and I'll definitely look into the crash you described with telemetry/logging, and the log file name issue. The Mac version got significantly less testing than Windows, unfortunately. I also noticed/fixed a minor bug with the Connect/Disconnect button labels.

I'm not sure about the issues with running the ESC... The "ESC unexpectedly entered disarmed state" (when it is actually still running) problem can be due to telemetry data getting mixed up (it would also display "funny" values in the list/graph). Though if you didn't have a problem with the calibration run, that would suggest a decent USB cable/etc. How many Hz is the telemetry rate set to, and does that make a difference for this issue?

Before trying to run at a fixed RPM, I assume you set the FF terms on the ESC after the initial calibration? You could also try running from the command line interface to see if it makes any difference.


Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Mon Aug 31, 2015 9:07 am
by Astudillo
Hi Max,

Thanks for your reply, yes i saved the FF terms to permanent memory and rebooted. I ran the telemetry at 10Hz, i could try different rates. And ill check the Terminal.

Thanks for the input!

Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Tue Sep 01, 2015 5:55 pm
by Max
Update 1.0.1 is now available for Mac OS X. Fixes packaging problem with the Qt libraries, Connect/Disconnect button label, and default telemetry file name. Remaining known issue: app crash if logging is stopped while telemetry is running (will fix on next update).

Installer download link updated. If you already installed ECU, you can update using the included utility.

Thanks again to Ray for the reports!


Re: Introducing the AQ ESC32 Configuration Utility (ECU)

PostPosted: Tue Sep 01, 2015 6:40 pm
by kinderkram
I´ve added a note to the docu regarding the app crash.
Remove after the fix.