Flashing stopped and ESC not responding anymore

Info and Discussion about the ESC32 hardware and software

Flashing stopped and ESC not responding anymore

Postby DUKE40 » Mon Sep 15, 2014 6:38 pm

Hi,

I was just flashing my ESC to the latest FW r57.
Around 33.59% it just stopped progressing and nothing else happened.
QGC ran into a timeout and crashed.
Since then the ESC32 seems to be dead
When connecting it to QGC no led flashes.

Trying to flash again Iget the message
stm32flash failed to connect on COM3
with error: Process operations timed out.

What can I do to get my ESC back alive? Is there anything I can do, or do I have to get in contact with Flyduino to get this sorted out?
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Flashing stopped and ESC not responding anymore

Postby DUKE40 » Mon Sep 15, 2014 8:12 pm

I have already contacted Flyduino, but they never had such situation and are not able to provide any advise how to proceed on this particular issue.
Hope someone here will be able to help me out.
Otherwise, I will have to consider the ESC as dead and lost.
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Flashing stopped and ESC not responding anymore

Postby LPR » Mon Sep 15, 2014 8:38 pm

Does the red LED go on when the ESC32 is powered?

Larry
LPR
 
Posts: 1323
Joined: Tue Jun 26, 2012 1:29 pm
Location: MN, USA

Re: Flashing stopped and ESC not responding anymore

Postby DUKE40 » Mon Sep 15, 2014 8:46 pm

No, the red LED does not go on anymore. :evil:
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Flashing stopped and ESC not responding anymore

Postby JussiH » Mon Sep 15, 2014 11:49 pm

Sounds like something failed in the power supply during flash, have you checked powersupply or tried supplying via the v5 input?

If its dead, you can send the ESC here and I will take a look at it. Usually the bootloader doesnt fail but I had one that did the same thing but I got it working after flashing FW again via SWD.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Flashing stopped and ESC not responding anymore

Postby DUKE40 » Tue Sep 16, 2014 5:13 am

I will check power supply this afternoon.
I always use v5 inpout as power supply, as the copter wil be powered with 4S and it is recommended then to have the ESC not powered directly from the main power supply.
So v5 is connected and not vb.
I will check the solders of the FTDI connector, the problem might be there.
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Flashing stopped and ESC not responding anymore

Postby sandmen » Tue Sep 16, 2014 8:32 am

Solder the boot jumper.
Connect power and flash again.
Should not be dead.
sandmen
 
Posts: 997
Joined: Fri Jun 22, 2012 7:25 am

Re: Flashing stopped and ESC not responding anymore

Postby DUKE40 » Tue Sep 16, 2014 8:48 am

Hi sandmen,

thanks for this hint, but this is exactly what I have done.
Boot jumper is soldered, but flashing does not work.
Boot jumper opened, no LED showing any sign of life.
Power is set to v5, no battery connected at all, only 4 wires on FTDI (GND, 5V, TX and RX).
I fear I will have to either flash it through SWD if this is something I could do (no idea how this is done), or send it to Jussi in the hope he will be able to do it.
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Re: Flashing stopped and ESC not responding anymore

Postby JussiH » Tue Sep 16, 2014 10:50 am

If you dont have experience with SWD (Serial Wire Debug), its probably nothing to get into for just a single ESC. Send it here and I will care for it under warranty!

If you wanted to play with SWD, the cheapest option is to get a STM32F4 discovery board as its pretty cheap and comes with a ST-link SWD interface onboard. Its a reasonably cheap board, I think I payed something like 15E for mine.
JussiH
 
Posts: 2103
Joined: Thu Jun 21, 2012 9:25 pm

Re: Flashing stopped and ESC not responding anymore

Postby DUKE40 » Tue Sep 16, 2014 12:34 pm

Hi Jussi,

Ok, then it seems clear to me, I will have to send it in.
I have checked power supply, and there is no issue there everything is fine, all solders have contact.
Best regards,
Image
Spacewalk 550, MT2216-11, SimonK 20A ESC, AQ6 DIMU, 10x5" CF, SJ4000
CamCruiser, MN3510, ESC32, AQ6 DIMU, 12x4" CF, SimpleBGC, GoPro Hero 3 BE
DUKE40
 
Posts: 364
Joined: Tue Mar 26, 2013 9:49 pm

Next

Return to ESC32

Who is online

Users browsing this forum: No registered users and 4 guests

cron