qgc compile error under ubuntu with latest source code

For everything that doesn't fit into the other (sub-) forums

qgc compile error under ubuntu with latest source code

Postby jy0933 » Sat Oct 05, 2013 11:35 am

source was newly cloned from git
qt version 4.8
qtspeech installed/loaded correctly with script

compiled source code no problem before (about 3 months ago)

current compile error message in attached screenshot

I use ubuntu extensively, and it is more stable than windows.


side note, origial qgc compiles successfully. Not sure what is causing it. I might erase everything and see if i can build on a fresh system env.

error message

/home/james/code/qgroundcontrol/libs/QtSpeech/festival/speech_tools/lib/libestools.a(editline.o): In function `readline':
editline.c:(.text+0x7824): undefined reference to `tgetent'
editline.c:(.text+0x7847): undefined reference to `tgetstr'
editline.c:(.text+0x7860): undefined reference to `tgetstr'
editline.c:(.text+0x7879): undefined reference to `tgetstr'
editline.c:(.text+0x7892): undefined reference to `tgetstr'
editline.c:(.text+0x7912): undefined reference to `tgetstr'
editline.c:(.text+0x7939): undefined reference to `tgetnum'
editline.c:(.text+0x794a): undefined reference to `tgetnum'
editline.c:(.text+0x7a44): undefined reference to `tgetstr'
collect2: ld returned 1 exit status
make: Leaving directory `/home/james/code/qgroundcontrol-build-desktop-Desktop_Qt_4_8_1_for_GCC__Qt_SDK__Release'
Attachments
660e95a8-2c7d-11e3-9de0-3f2b6311c715 (1).png
jy0933
 
Posts: 8
Joined: Thu Oct 03, 2013 11:35 pm

Re: qgc compile error under ubuntu with latest source code

Postby Max » Sat Oct 05, 2013 9:54 pm

I've never seen this error. I did recently add the speech/festival lib for Linux, so perhaps that is causing issues. One thing I do notice is your Qt build config says Qt version 4.8.1. We're using 4.8.4.

Did festival install OK and did the speech test work?

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: qgc compile error under ubuntu with latest source code

Postby jy0933 » Sat Oct 05, 2013 10:05 pm

i have done a few tracking earlier. 4.8.1 can compile ok up to commit #79a66fa9e45e550fc7ef246625e71a53ba90ad09. The next commit to this is the implementation of QtSpeech. that's where the error comes about.

festival installed ok and tested fine (at the end of installation)
jy0933
 
Posts: 8
Joined: Thu Oct 03, 2013 11:35 pm

Re: qgc compile error under ubuntu with latest source code

Postby Max » Tue Oct 08, 2013 2:12 pm

James, if festival won't work for some reason, you can revert just the offending commit and it shouldn't break any later changes. I would also try updating Qt though, just for kicks.

Cheers,
-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: qgc compile error under ubuntu with latest source code

Postby jy0933 » Tue Oct 08, 2013 8:35 pm

it works after reverted the specific commit. I'll do a clean installation of 4.8.4 on vitual machine and see if that was the problem.
jy0933
 
Posts: 8
Joined: Thu Oct 03, 2013 11:35 pm

Re: qgc compile error under ubuntu with latest source code

Postby afernan » Thu Dec 05, 2013 2:55 pm

I´m having problems when installing "festival" some errors occured, and then I can´t compile QGC using Qtcreator.

Any sugestion?

Thanks

Angel
afernan
 
Posts: 1214
Joined: Sat Jul 07, 2012 5:24 pm
Location: Madrid, Spain

Re: qgc compile error under ubuntu with latest source code

Postby Max » Sat Dec 07, 2013 11:56 pm

Angel, would need more info about errors to help. Your best bet would probably be to Google for solutions to whatever festival build errors you're getting. Or revert the commit as mentioned above. In the future I'll try to make it easier to build versions w/out speech support, since that can be an annoying extra step on Win and Linux.

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: qgc compile error under ubuntu with latest source code

Postby Max » Sat Dec 14, 2013 4:13 pm

I just built QGC on Ubuntu 13.10 (actually LUbuntu). Basically following the instructions worked... though I also added festival-dev to the apt-get install list. I did get a bunch of errors when running get-festival.sh, but it didn't seem to matter (might try to clean that up later).

I uploaded the build here -- ftp://ftp.autoquad.org/3/334693_22529/g ... 2.2.tar.gz

If you try the build please let me know if it works for you or not. You may need to make sure phonon and festival runtime packages are installed -- apt-get install phonon festival

-Max
Max
 
Posts: 2814
Joined: Mon Aug 13, 2012 9:45 pm
Location: Near Ithaca, NY, USA

Re: qgc compile error under ubuntu with latest source code

Postby afernan » Sun Dec 15, 2013 11:10 am

Hi Max. Thanks for the work:

I´ll try that and will go back to you

Angel
afernan
 
Posts: 1214
Joined: Sat Jul 07, 2012 5:24 pm
Location: Madrid, Spain


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 4 guests

cron